Widgets stopped working on 3D scenes

06-17-2021 06:55 AM
Labels (1)
New Contributor II

After updating arcgis enterprise to version 10.9, widgets stopped working and displayed on the 3D scene. Republishing the 3d scene and widgets did not help, nor did trying to publish the widgets on a new scene. We tried to take widgets from the examples presented in WebApp Builder 2.19, the same - widget is not displayed on the 3d scene.

Arcgis enterprise version 10.9

WebApp Builder version 2.19

JS API version 4.19


    "name": "HistoricalOM",
    "2D": false,
    "3D": true,
    "platform": "HTML3D",
    "version": "1.0",
    "wabVersion": "2.19",
    "author": "Sibanthracite",
    "description": "Historical Ortho",
    "properties": {
        "inPanel": true,
        "hasUIFile": false,
        "hasConfig": false,
        "mirrorIconForRTL": true


No errors are displayed in the console.

For 2D scenes, everything works fine.

Maybe someone came across a similar problem and solved it?

1 Reply
Esri Contributor

i'm having the same issue.  @SibanthraciteGIS did you ever find a resolution?

0 Kudos