WebApp changes within the Builder are not applied to the "Final"-WebApp

2335
6
10-07-2015 05:45 AM
ThomasSteudel1
Occasional Contributor

Hi alls,

i created a WebApp with a Query Widget - everything worked fine until i had to change the title within the "Box Controller"

What happend?

My WebApp within the WebApp-Builder (btw. does it autosave the settings now? - I am not able to press the "Speichern (Save)" Button anymore). The red circle within the upper-right corner is showing my "problem". Within the Web-App Builder i put there the title "Kindertagesstätten". Everything is fine. Builder tells me that everything is (auto?)saved. I changed the text within the "Attribut" (Branding) Option

Preview_Builder_Version.PNG

If i do a preview to see how everything will look like on a mobile device - everything is fine.

Now the problem - when i start the application out of the Builder, i will get the following (the text within the red circle is the text which was in there before i changed it to Kindertagesstätten:

Preview_Final_Version.PNG

Here is the direct link to the application: ArcGIS Web Application

I tried alot (cleaning my cache, using different browsers to configure) and i really do not want to rebuiled the whole Application. Does anyone know if this is a bug?

Maybe someone can help me.

Thanks in advice and best regards,

Thomas

P.S: I think it is a bug and the reason could be, that it is not possible (for me) to save my changes within the "Box Design" Theme anymore. Question is why???

Nachricht geändert durch Thomas Steudel

0 Kudos
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Thomas,

   I am pretty confused. Using your link above I get this when I go to your site. I don't see anything like what you are displaying in your screenshots.

Sample.jpg

0 Kudos
ThomasSteudel1
Occasional Contributor

Hi Robert,

due to my tries to change it by switiching between themes "destroyed" the application. But the problem is there....in the upper right corner (menue) click on the filter-icon and the window (box controller) should close itself and you can see the box with the wrong text. I do not know why i was not able to save my changes in the webapp-Builder anymore.

Best regards and sorry for the confusion

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Thomas,

   When you have the box theme's box controller open to the query widget the title is "Suchen" when you click on the query icon again the box controller is minimized and the App's Title appears as the text (as it should).

0 Kudos
ThomasSteudel1
Occasional Contributor

Hi Robert,

i know that it should show it - but it did not (my first screenshot is made within the WebApp-Builder Application, the second one using the public available URL.

I figured out, that the problem was, that i was not able to save any changes within the WebApp-Builder. The reason i do not know. Now i had to start from the scretch .

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Thomas,

   Are you saying that there is nothing that you can change in your app that will cause the save button to enable? Have you tried changing other properties?

0 Kudos
ThomasSteudel1
Occasional Contributor

Hi Robert,

Yes that was the cause why i could not apply my changes.

To solve it: I tried switching within the AppBuilder to another Theme - of course it changed all the settings buw i was able to save only one time. Now i created a completely new app to reproduce the content of the old one (where i could not save). I tried alot. Also logging out, cleaning cache or using different browsers - nothing solved the problem. Now within the new app everything works fine.

Thanks for the effort to help!

Many regards,


Thomas

0 Kudos