WebApp Builder for ArcGIS username and password issue

3355
3
Jump to solution
04-14-2016 09:15 AM
HabG_
by
Occasional Contributor

Hi All

I have created a secure service (Using GIS Server Authentication Tier) on ArcGIS Server and published it as a web map in ArcGIS Online. I have created a web mapping application in WAB and when I launched the app from WAB the Sign In page displays and I am able to sign in using the username and password I have created in my ArcGIS Server Manager Configuration Settings. However, when I downloaded the app and copied it to the wwwroot directory and browse for the app, I cannot sign in using the same username and password.

WABSignIn.png WABSignIn.png

Is there any configuration I need to apply in order to sign in using the same credentials?

Thanks

0 Kudos
1 Solution

Accepted Solutions
TobiasFimpel1
Occasional Contributor III

Regarding your screenshots: One of the prompts asks you to authenticate to ArcGIS Online (in order to access the item). Use your ArcGIS Online username and password there, or else share the item (likely the webmap) publicly . The other one asks you to authenticate to your ArcGIS Server site, use your ArcGIS Server credentials there. If this is already what you are doing then disregard, just wanted to make sure you know this. -Tobias

View solution in original post

3 Replies
ronaldmcfarlane
Occasional Contributor

Have you tried preceding your login name with the domain name?  e.g., "myCompany\myuser".  That is what I have to do with my system.

0 Kudos
TobiasFimpel1
Occasional Contributor III

Regarding your screenshots: One of the prompts asks you to authenticate to ArcGIS Online (in order to access the item). Use your ArcGIS Online username and password there, or else share the item (likely the webmap) publicly . The other one asks you to authenticate to your ArcGIS Server site, use your ArcGIS Server credentials there. If this is already what you are doing then disregard, just wanted to make sure you know this. -Tobias

HabG_
by
Occasional Contributor

Thanks Tobias,

As you said it, my webmap was not shared publicly. Now I have shared it publicly and it is accepting the username and password. Thanks again.

Hab

0 Kudos