Web AppBuilder Removing commas from Smart Editor

11-16-2018 09:42 AM
New Contributor


I have a Web AppBuilder application that displays commas in numeric fields that have been configured to not display commas for values larger than 1000. We have also configured any date fields to be displayed as Month, Day, Year format but this does not format in the application as well (2nd image)

We have built a Web AppBuilder Application that uses the Jewel Box theme with the Smart Editor widget added to the left pane. But the values keep displaying with a comma. Second image is from the date field that is not formatting to our selected format.

We are using the developers edition and i am hoping that somebody could help us out by identifying which files need to be adjusted with some code. Similar to Liana Smith's issues 


6 Replies
Esri Contributor


I know it is an old post but just for reference I thought I should reply. This issue is not reproducible in the current version on WAB in ArcGIS Online and Smart Editor widget honors the comma separator settings for the layer.

I am able to reproduce the issue with Smart Editor widget in WAB. 

Also, there are some other widgets that still show the comma separator regardless of the layer settings from visualization tab or in web map pop ups. These include: 

  • Legend
  • Group Filter
  • Edit
  • Situation Awareness
  • Chart

There is an existing bug requesting to fix this issue.

All the best,


New Contributor II

MJ Biazar I am experiencing the same problem in web app builder (a field I have configured within "configure pop-ups" of my web map to not display thousand separator commas is still showing these within the Smart Editor widget in a Web App I have built). Any update on this issue? It seems like I have reproduced the same error as City of Kelowna GIS.  

0 Kudos
Esri Contributor

Ryker Garrett‌ After more testing I'm able to reproduce this issue with Smart Editor widget too. It seems like it still shows commas when you select a feature but when you click in the box the edit the values, the comma is gone. 

While the bugs are still being reviewed, as a workaround you can create a text field, and calculate values from the integer field to remove the commas in WAB widgets.



0 Kudos
Occasional Contributor II

This is still an issue more than a year later. Seems like something simple to fix. Why is this not being resolved? Creates confusion for end users resulting in service calls.

Occasional Contributor III

I am also still having this issue

New Contributor II

I'm having this issue too. I was able to fix it a month ago, although I'm not sure how. I added an additional layer to my map, one integer field displays without commas and one integer field displays with commas.


EDIT: I figured it out. Open the Web Map that is displayed in AppBuilder. View it in Web Map Viewer Classic --> configure pop-ups --> uncheck show thousands separator.

For whatever reason even if you do it in Web Map Viewer it may not go through to Classic and it seems like AppBuilder is reading the Classic options for thousands separators.

0 Kudos