Web AppBuilder not respecting removed service layers in saved AGOL map layers

3404
13
Jump to solution
05-01-2015 08:19 AM
MarkStelzel
New Contributor III

Hello everyone.  I have several AGOL map layers that were created by paring down larger map services.  When I point Web AppBuilder to a web map containing one of these map layers, the created web app displays all of the layers in the source map service rather than reduced number of layers of the AGOL map layer.  I hope that makes sense.  Am I missing something or is this a shortcoming/designed behavior of Web AppBuilder?  Please note, I am not using the developer version.  Thanks for the help!

0 Kudos
1 Solution

Accepted Solutions
MarkStelzel
New Contributor III

For anyone interested,  I recently followed up with ESRI support on this and was glad to hear that release 3.9 will address this issue.  This is not the release scheduled for next month (July 2015) but the one following sometime in the fall.

View solution in original post

13 Replies
JeffWard
Regular Contributor II

Are they pared down using a query?

Jeff Ward
Summit County, Utah
0 Kudos
MarkStelzel
New Contributor III

Jeff, they are not.  I'll elaborate a bit more.  I have a map service with layers A through Z.  From an AGOL webmap, I remove all the layers except for B, D and F.  I then save this BDF layer to AGOL My Content.  While AGOL webmaps display only layers B,D and F, the Web AppBuilder app displays layers A-Z of the source map service.

0 Kudos
TomSellsted
MVP Regular Contributor

Mark,

Have you tried flushing your browser cache?

Regards,

Tom

0 Kudos
MarkStelzel
New Contributor III

Tom, I have tried clearing the cache.  That did not do the trick.

0 Kudos
TomSellsted
MVP Regular Contributor

Mark,

Any chance that you are using a widget that displays your services directly and not from your web map?

Regards,

Tom

0 Kudos
MarkStelzel
New Contributor III

That certainly appears to be the case.  Hopefully someone who knows the inner workings of the widgets and app can tell us definitively.  My hope was that the deep integration between Web AppBuilder and AGOL would allow this type of layer configuration to carry over just as popup configurations do.

0 Kudos
TomSellsted
MVP Regular Contributor

Mark,

Is the application published so we can view it and maybe figure out what is going on?  or URL for rest service or web map?

Regards,

Tom

JeffWard
Regular Contributor II

Have you tried creating a new map, adding the layer you created from the other map and creating the app from the new map?

Jeff Ward
Summit County, Utah
0 Kudos
MarkStelzel
New Contributor III

I've also tried that, yes.

0 Kudos