WAB Smart Editor Widget - feature templates not available

2087
8
01-11-2019 08:57 AM
BillSpiking__GISP
Occasional Contributor

Hello,

Has anyone had issues with feature templates not displaying in the Smart Editor widget after the December AGO update?  They're displaying fine in the standard Edit widget and in previous versions of the Smart Editor (ver. 2.8 according to the json code) but not in this latest release (ver. 2.11).

Any help would be appreciated.  

Thanks!

Bill

8 Replies
AleydisG__Pere
Occasional Contributor

Did you ever get a solution for this?

0 Kudos
MaryMcColley
New Contributor

I am also having the same issue. I confirmed that the layers pushed all have feature templates. Why would they not show under the Smart Editor widget in WAB?

0 Kudos
JohnGargiulo
New Contributor III

I just finished a call with ESRI support. There is a known bug where the layer template will not display in some Web Application Themes.  The known issue is with the Tab Theme, I was also experiencing the issue with the Foldable Theme.  Was finally able to get Smart Editor working with the Billboard theme.  I have not tried others yet. 

JoyRoberts1
New Contributor II

We appear to be experiencing it within the Launchpad Theme. I have three feature layers with four categories of features, and the widget simply shows the feature layer name without ANY templates. 

0 Kudos
RicciLucas
New Contributor II

I am having issues with most of the templates, but the ones I do get a Smart Editor icon for does not have the Smart Actions tab I need to edit my fields. Has there been any updates to this bug?

0 Kudos
PaulHickson1
Esri Contributor

BUG-000117282 -The Smart Editor widget in Web AppBuilder for ArcGIS app in Portal for ArcGIS fails to allow editing when added to the widget controller in the Tab theme.

Please request that you associate your accounts to the Bug so you can add weight to the progress.

WilliamRice
Occasional Contributor II

Paul,

What version of ArcGIS Enterprise are you using?  With the Smart Editor widget, I cannot get the editing template to appear for an ArcGIS Server Feature Service for any of the WAB themes.  The Editor widget however works fine.  I am using ArcGIS Enterprise version 10.8.

0 Kudos
AlixVezina
Esri Regular Contributor

This is resolved in later versions of the widget. You may want to consider upgrading to a later version of Enterprise or using the latest version of the Smart Editor widget as a custom widget for their applications.

0 Kudos