WAB Smart Editor Attribute Action - Intersection not populating from point layers

2326
7
02-01-2019 10:57 AM
Highlighted
New Contributor III

I have a fairly simple WAB with a number of point and line feature classes added.  I set up a Smart Editor Attribute Action (details in Smart Editor widget—Web AppBuilder for ArcGIS | ArcGIS ) that should populate the field of a newly created line with the value from a point this new line intersect.  If doesn't matter which point layer I draw the line through, the Attribute Action does not work.  If I set it up to get a value from a line or polygon to populate a field in the newly created line, it works just fine.  

I don't see anything in the documentation about this functionality NOT working with point feature layers.  Is this a bug?

7 Replies
Highlighted
MVP Esteemed Contributor

Pam,

  More likely it is the precision that would me need to get a line to actually intersect a point and the unlikely hood of you being able to do this by interactively drawing a line on the map.

Reply
0 Kudos
Highlighted
New Contributor III

That was my assumption but even if I zoomed in as much as I possibly could and ran the line right through the middle, I never got a hit. If this wasn't an editable application, I would just create buffers of the points but I don't think there is a way to create buffers on the fly when new points are added.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Pam,

 Even zooming in all the way (assuming you are using an esri basemap then you are still confined to the LOD scales the basemap is created for) that would not be enough to make a line intersect a point by drawing. It's just not going to happen unless a you have a freak accident and hit the Lottery.

Reply
0 Kudos
Highlighted
New Contributor III

A girl can dream!  Well, at least I now know that that is the likely reason and I didn't have the configurations all futzed up.

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Pam and Robert,

We are aware of this limitation and we are reviewing this capability for a future update.

Thank you,

Alix

Highlighted
New Contributor III

Thanks Alix.  It would be great if you could set some kind of identification tolerance.

Highlighted
Esri Contributor

Hi Pam,

When setting up an intersection line or polygon against a point layer, please use the other tolerance units. Pixel tolerance will only apply for point to point intersections. This can be configured directly against the layer in the intersection attribute action or in the layer settings (in this case check the box for "Use Default Tolerance").

Reply
0 Kudos