WAB Developer only publishing locally

1202
11
Jump to solution
02-01-2017 07:41 AM
travisslack1
New Contributor III

Hey guys,

I have WAB developer edition installed and can enter my portal URL fine, but when I export as a template and import on my portal site, the URL for the web app is https://local.machiene.name/webappbuilder as opposed to https://web.domain.com/blah/blah. When I launch the WAB Developer using startup.bat I specify my portal address as https://web.domain.com/arcgis/

This isn't letting anyone but me view the app. Am I missing a step here? Thanks

WAB Developer does not have to be run on the server that houses portal/server right?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
DerekLaw
Community Moderator

Hi Travis,

Ok, I think I understand your issue now.

By default, when you create a new web app or template in Web AppBuilder Developer Edition, it is hosted on the same machine where Web AppBuilder Developer Edition is installed. When you choose to export a template to "My Organization", the exported template item will use the default app URL from Web AppBuilder - which is the URL for Developer Edition. See the Export dialog screenshot red text:

Export as Template

So what you're seeing is expected. The new template is a Portal item, but still references the template that is hosted in Web AppBuilder Developer Edition on your local machine. If you want other users to be able to access the template, you may want to host it on another web server that the other uses can access. Does this make sense?

If you use Web AppBuilder embedded within Portal for ArcGIS to create your web app template, then it will live within Portal and be accessible to other Portal users.

Hope this helps,

View solution in original post

11 Replies
DerekLaw
Community Moderator

Hi Travis,

> ... when I export as a template and import on my portal site ...

Q1) What do you mean by "portal site"? Are you connecting Web AppBuilder for ArcGIS Developer Edition to an ArcGIS Online organization or a Portal for ArcGIS instance?

When you create a new template in Web AppBuilder for ArcGIS Developer Edition, you have the option to export it directly to the "organization" or to your local Server.

Q2) Did you choose to export to "My Organization"?

> This isn't letting anyone but me view the app. Am I missing a step here?

By default, when you create a new item in both ArcGIS Online or Portal for ArcGIS, it is private and only the item owner can see it. You have to set its sharing properties to enable other members of your portal to access and see it.

 

> WAB Developer does not have to be run on the server that houses portal/server right?

Correct. It can be installed on a separate machine from Portal for ArcGIS/ArcGIS Server.

Hope this helps,

0 Kudos
travisslack1
New Contributor III

Hey Derek, 

>What do you mean by "portal site"?

I mean the portal site I am running on my server, not connecting to ArcGIS Online. 

>When you create a new template in Web AppBuilder for ArcGIS Developer Edition, you have the option to export it directly to the "organization" or to your local Server.

I've tried that as well be it keeps publishing the local machine name as the URL to access instead of the web.domain.com URL which EVERYONE can access. 

>By default, when you create a new item in both ArcGIS Online or Portal for ArcGIS, it is private and only the item owner can see it. You have to set its sharing properties to enable other members of your portal to access and see it.

I don't mean the sharing feature, I mean because the app is being published with the URL as my own machien name vs the web.domain.com people connecting outside of the domain would have no way to access it. 

Thanks for the help

0 Kudos
DerekLaw
Community Moderator

Hi Travis,

> ... the app is being published with the URL as my own machine name vs the web.domain.com people connecting outside of the domain would have no way to access it.

Is the machine with Portal for ArcGIS installed and the other machine with Web AppBuilder Developer Edition installed on the same domain? Are they both on a physical network? What kind of security has been configured for Portal?

When you export a template from Web AppBuilder Developer Edition to "My Organization", it should create a new item in your Portal with the Portal's URL address.

Hope this helps,

0 Kudos
travisslack1
New Contributor III

>Is the machine with Portal for ArcGIS installed and the other machine with Web AppBuilder Developer Edition installed on the same domain? Are they both on a physical network? What kind of security has been configured for Portal?

No, AGS/Portal are on vgfsjfs1.vgfsj.local and im running WAB developer from vgfsj.local but i get the same issue if i run wab developer on the server portal/ags are on.  I took some screen shots to help clarify what I am talking about. This happens whether I import template as well. 

0 Kudos
DerekLaw
Community Moderator

Hi Travis,

Ok, I think I understand your issue now.

By default, when you create a new web app or template in Web AppBuilder Developer Edition, it is hosted on the same machine where Web AppBuilder Developer Edition is installed. When you choose to export a template to "My Organization", the exported template item will use the default app URL from Web AppBuilder - which is the URL for Developer Edition. See the Export dialog screenshot red text:

Export as Template

So what you're seeing is expected. The new template is a Portal item, but still references the template that is hosted in Web AppBuilder Developer Edition on your local machine. If you want other users to be able to access the template, you may want to host it on another web server that the other uses can access. Does this make sense?

If you use Web AppBuilder embedded within Portal for ArcGIS to create your web app template, then it will live within Portal and be accessible to other Portal users.

Hope this helps,

View solution in original post

NadineTrahan1
New Contributor III

Derek, I am having this same issue. I think I understand what you are saying the problem is, but I don't get the resolution. After customizing my app, I want to then use it in ArcGIS Online, in order to build an that will be accessed by the public. Can I not host my customized app on ArcGIS Online if I have an account there?

Thanks,

Nadine

0 Kudos
DerekLaw
Community Moderator

Hi Nadine,

> Can I not host my customized app on ArcGIS Online if I have an account there?

ArcGIS Online does not support direct hosting of custom apps. For custom apps, you would host them on your own publicly accessible web server, then you can register the custom app as a new item in ArcGIS Online. You can register the app by adding it as a new item (e.g., a web app) and simply reference the URL location of where your custom app is hosted. In this way, people can search and find your custom app in ArcGIS Online - but when they click to open the app, they would be redirected to your custom app on your own web server.

Add items—ArcGIS Online Help | ArcGIS 

Hope this helps,

0 Kudos
travisslack1
New Contributor III

Thanks for the help thus far Derek. I went and downloaded the app from Web AppBuilder, put it in inetpub/wwwroot/apps/test but when I access it https://web.domain.com/apps/test I am stuck 

at the loading screen it doesn't want to progress. any ideas?

thanks again 

EDIT: I Think I got it, i was building the web app with the self signed cert instead of my ca signed cert. seems to be ok right now.  Im gonna mark your last answer as correct as that got me to this point and solved the issue. Thanks!

0 Kudos
NadineTrahan1
New Contributor III

Travis, I'm having a similar issue. I simply don't get how to serve my customized app via ArcGIS Online, instead of from my local pc. Could you please elaborate on how you resolved your issue, this may give me a clue on what I am missing. Specifically, where did you access the certificate info an what is 'ca' signed exactly. Thanks for any help.

0 Kudos