WAB and ArcGIS API for JavaScript 4.0

2690
8
Jump to solution
03-11-2016 02:30 PM
MaterMaps
New Contributor II

Does WAB (any release) work with the 4.0 JavaScript APIs?

Would WAB continue to be the vehicle for developing apps @ 4.0.

Basically, if I want to work with ArcGIS API for JavaScript 4 / Portal, is WAB the right tool?

Web AppBuilder for ArcGIS

Web Developers

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Mater Maps,

   I have many custom widgets out there and I have spoken at length with the development team and JS API team and the changes in the JS API going from 3.x to 4.0 are significant and as WAB is built using the JS API these changes affect the WAB product. The 4.0 JS API is still in Beta right now and the WAB 2.0 is Beta as well as the 2D portion still uses the JS API 3.x and the new 3D capability in WAB 2.0 (Beta) is using the JS API 4.0 (Beta). The JS API should be 4.0 final by the UC and the WAB 2.0.

View solution in original post

8 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

WAB 2.0 (which is expected to be released in the next couple weeks) will use Js4.0 for the new 3D, but not for 2d this release. 

The bad news for you is you will have to wait a bit if you need WAB for 2D and JS 4.

the good news is the custom widgets won't all be broken (they will need to be rewritten for 4.0).

Robert Scheitlin, GISP​   Please correct my statement if needed.

MaterMaps
New Contributor II

the good news is the custom widgets won't all be broken (they will need to be rewritten for 4.0).

Thanks Rebecca Strauch, GISP

So, it's more wait time.  Investing time to build 2D widgets in WAB 1.x and then "rewriting" for JS 4.0 in WAB 2.0 - does not seem to be a right progression.

Can someone from ESRI Web AppBuilder for ArcGIS​ team confirm and provide some timelines?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Mater Maps,

   I have many custom widgets out there and I have spoken at length with the development team and JS API team and the changes in the JS API going from 3.x to 4.0 are significant and as WAB is built using the JS API these changes affect the WAB product. The 4.0 JS API is still in Beta right now and the WAB 2.0 is Beta as well as the 2D portion still uses the JS API 3.x and the new 3D capability in WAB 2.0 (Beta) is using the JS API 4.0 (Beta). The JS API should be 4.0 final by the UC and the WAB 2.0.

View solution in original post

MaterMaps
New Contributor II

Thanks a lot for your response Robert​​

The apprehensions with which I started this thread, came true. I've been keeping away from this platform for a while and seems, will have to continue doing that for some more time. Appreciate, all your help.

0 Kudos
JoeHershman
MVP Regular Contributor

Robert Scheitlin, GISP‌, Rebecca Strauch, GISP

Any idea on why they have still not updated the default API for WAB 2D widgets.  4x has been out for a while and one would think esri would have made the effort (started laughing as I typed that) to bring things into the current API 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Joe,

   They will Not be updating WAB 2D to use the 4.x API there is whole over product called experience Builder that is the new thing that is built using the 4.x API that is in Beta right now.

LeslieWeiner-Leandro
Esri Contributor

What's the release date for Esri Javascript API 4.0? Thx.

0 Kudos
BrentonWonders
New Contributor II

Last we heard, I think the JS API v4.0 is supposed to be out of beta within the next few weeks. 

0 Kudos