WAB AGOL - Public Notification Widget

998
13
Jump to solution
01-02-2018 10:43 AM
RickeyFight
MVP Regular Contributor

I am getting a weird error where my exports now have an  after each attribute. 

 

Example:

Name Here 391E09AC 500 MAIN ST ASHLAND, OR 97520

 

Should be:

Name Here 391E09AC 500 MAIN ST ASHLAND, OR 97520

 Any ideas why this is happening? 

0 Kudos
1 Solution

Accepted Solutions
ChrisBuscaglia
Esri Contributor

This has been officially released and is available.  

Public Notification | ArcGIS for Local Government 

Please let technical support know if you run into any issues.

Thanks 

Chris

View solution in original post

0 Kudos
13 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Rickey,

   Does your data have a new line/ carriage return in those spots?

0 Kudos
RickeyFight
MVP Regular Contributor

Yes it does. I see this while exporting to excel 

Popup Code:

{MAPNUMBER} {TAXLOT}<br /> {FEEOWNER}<br />{ADDRESS1}<br />{CITY}, {STATE} {ZIPCODE}‍
0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Hmm, sounds like the widget is not setup to handle that then.

0 Kudos
CCWeedcontrol
Regular Contributor

You have spaces at the end of the fields. I had that problem.

CCWeedcontrol
Regular Contributor

I should be more specific.

In the Layer Custom Attribute Display

{OwnerName} <- you have space after the curly brackets

RickeyFight
MVP Regular Contributor

Well the problem is that I am using multiple fields 

{MAPNUMBER} {TAXLOT}
{FEEOWNER}
{ADDRESS1}
{CITY}, {STATE} {ZIPCODE}

So I have to have spaces. 

0 Kudos
AllisonMuise1
Regular Contributor

Yes, that makes sense. Are you getting the special characters in ALL the spaces, or just at the line breaks? It looks to me just the line breaks, in which case removing the spaces at the ends of the lines should address the issue. The spaces between field values on each line should be fine.

RickeyFight
MVP Regular Contributor

It seems to be happening between fields not just line breaks

Here is my site:

ArcGIS Web Application 

What my popup is configured to show. 

{MAPNUMBER} {TAXLOT}
{FEEOWNER}
{ADDRESS1}
{CITY}, {STATE} {ZIPCODE}

Result (not a real result but what is happening) 

{MAPNUMBER} {TAXLOT}
{FEEOWNER}
{ADDRESS1}
{CITY}, {STATE} {ZIPCODE}

JonathanSkloven-Gill
New Contributor III

So is there any way to address this issue aside from combining fields in desktop, or removing spaces between fields? Having:

{OWNER}

{ADDRESS}

{CITY},{STATE},{ZIP}

looks a little sloppy

0 Kudos