Splash - Remove text background color

3126
5
Jump to solution
12-08-2015 06:52 AM
Pierre-LucBoivin
Occasional Contributor

Hi,

I'm trying to clear the text background color of the splash windows and even if I put white, I still have problem with it.

Backsplash.JPG

Does anyone else have this problem and solved it ? 

Thanks you

0 Kudos
1 Solution

Accepted Solutions
TracyGarrison
New Contributor III

As the others have said you can fix this by using the developers edition of the web app builder.  But if you don't want to mess with that and you have a image editor like paintshop pro, capable of producing a png  image (with transparency)with your text and no background.  I have others who are asking me to create these web apps for them because of little issues like these.  So I did find this work around and it works.  When you go to insert your PNG image containing the text you have to set the filter to show all file types because they don't have PNG on their filter list (but it works).   I have a disclaimer that I am keeping in an psimage file that I created for my users to edit to change the text to whatever they want and then they just export that file to a PNG.  Now they can do it themselves until this problem gets fixed.  The following is a PNG file with the background transparent.Disclaimer2.png

View solution in original post

5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Pierre-Luc,

Once you have set the text background color there is no way in the UI to remove it, but you can open the config_Splash.json and remove it there:

i.e [install dir]\server\apps\[app #]\configs\Splash\config_Splash.json

{

  "splash": {

    "splashContent": "<div style=\"text-align: left;\">\n\t<span style=\"background-color: rgb(255, 255, 255);\">Blah, blah, blah, blah, blah, blah, blah, blah, blah, blah, blah, blah, blah,<br /> blah, blah, blah, blah, blah, blah, blah, blah, blah, blah, blah, blah,<br /> blah, blah, blah, blah, blah, blah, blah, blah, blah, blah, blah, blah,\n</span></div>",

    "requireConfirm": true,

    "confirmText": "I agree to the above terms and conditions",

    "showOption": true

  }

}

Just delete style=\"background-color: rgb(255, 255, 255);\" from the span element.

Pierre-LucBoivin
Occasional Contributor

I'm not using any ArcGIS Server for the moment so I guess, the only option is to disable it for now.

Thanks for your answer

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Robert's response is a change in the Web App Builder developer edition, not ArcGIS Server.  But my guess is that you are just using the online version of the WAB, and not the dev edition?   Unfortunately, this Geonet group catches all versions of the Web AppBuilder (Online, dev edition and Portal).....or course that can be a good thing since they all have things in common.

TracyGarrison
New Contributor III

As the others have said you can fix this by using the developers edition of the web app builder.  But if you don't want to mess with that and you have a image editor like paintshop pro, capable of producing a png  image (with transparency)with your text and no background.  I have others who are asking me to create these web apps for them because of little issues like these.  So I did find this work around and it works.  When you go to insert your PNG image containing the text you have to set the filter to show all file types because they don't have PNG on their filter list (but it works).   I have a disclaimer that I am keeping in an psimage file that I created for my users to edit to change the text to whatever they want and then they just export that file to a PNG.  Now they can do it themselves until this problem gets fixed.  The following is a PNG file with the background transparent.Disclaimer2.png

View solution in original post

RobertScheitlin__GISP
MVP Esteemed Contributor

Pierre-Luc,

   If one of the replies answered your question then please mark it as the Correct Answer.

To do this you have to open the thread (you can not see the correct answer link from inside your inbox) and then you will see the green star with correct answer link. Just click that link on the thread that answered your question.