Secure SSL services in Web App builder failing.

07-25-2015 05:24 PM
Occasional Contributor III


What I want:

Have a Secure Service on ArcGIS Server and add it to Web app builder ultimately in a web service where that little prompt comes up. (Easy right?)

This process has no issue if NOT SSL.

1.     http://MACHINE:6080/arcgis/rest/services/TEST/TEST/MapServer

2.     Create New Web Map

3.     Web Map prompts user for credentials for the secure service

4.     Save Web Map

5.     Create Web App   .. the prompt again appears when loading

Now... I want SSL so...

on IIS, I create a Redirect for all HTTP traffic to go HTTPS (443).

1.  Server admin >> changed to HTTPS only

2.  Change Portal to SSL

3.  Create new Web Map

4     Web Map prompts user for credentials for the secure service  - SO far this looks promising

5.   Save Web Map

6.  Create Web APP -  and..... no layers...

same thing happens both with ONLINE and Portal.

How does one properly have Secure Map Services from ArcGIS Server show up in a web application HTTPS only??

I have tried going through the web adaptor...

I have tried HTTP and HTTPS blend

I have tried all kinds of things... I can only seem to get this to work with HTTP.

Has no problem using ?jsapi from ArcGIS Server to push the prompt..

Why does Web APP BUILDER NOT SHOW THIS when using HTTPS?

IT works as expected with HTTP...


0 Kudos
17 Replies
Occasional Contributor III

I should add..

I have Zero problems manually obtaining token from ArcGIS Server and seeing the HTTPS secure service...

when changing to HTTPS for server I would go to      https://Machinename:6443/arcgis/rest/services//TEST/TEST/MapServer 

0 Kudos
Occasional Contributor III

and Another question. I found that Online Embeds the credentials when creating the WEB APP with HTTP, how does one DISABLE this?

0 Kudos
by Esri Contributor
Esri Contributor

Hi Michael,

Because I can't access your service url, so I can't look into it.

To find the problem quickly, my suggession is you can create an app using a template insteadof Web AppBuilder.

Here are the steps:

1. Create a new web map

2. Add your service into the web map

3. Save the web map

4. Click "Share" and the share dialog shows up

5. Click "MAKE A WEB APPLICATION" button, another dialog shows up

6. Select the "Configurable Apps" dialog and select any template, such as "Basic Viewer", then click "Publish"

7. Input the title and click "SAVE & PUBLISH" button

8. You can check the newly created app can show IdentifyManager dialog or not.

If it shows the IdentifyManager dialog and Web AppBuilder doesn't, it means it shoule be a bug of Web AppBuilder. If it also can't shows the IdentifyManager dialog, it maybe something else wrong...

0 Kudos
Occasional Contributor III


thank you for responding.

Unfortunately, i have went through the outlined process already.

The dialog shows up during the WEB MAP creation.. but does not when creating the web APPLICATION, regardless if choosing web app builder or 'basic templates'.  The same as I had outlined using Portal in the above posts.

do you have contact information to troubleshoot this in detail? - But I cant have you see that stuff.. so i added another..

User: PleaseWork

Password: Test

Or is there a precise step to ensure SSL works from start to end?

-Server set to HTTPS ONLY  - CHECK

-Server Authentication Tier - GIS_SERVER

- ive tried services through both Port 6443 OR web adaptor

-all items under 'default website' / arcgis - has Redirect rule set (HTTP to HTTPS) - CHECK (alternatively, can set the 'Require SSL') (but then Redirect does not occur).

- Portal set to SSL only. - CHECK

-Portal uses:

-IIS - Binding 443


It is funny, I have a working start to end (secure services and HTTPS) if I use Windows Authentication, add the Windows Authentication to Server and have the Browser challenge the user.  But to get this web app builder to do it.. Ive never seen it happen.. yet.

Esri Notable Contributor

Are you ensuring you're not mixing content at all?  For example, a service accessed over https can only be consumed in the web map, web app builder, and resulting web app over https.  If you know you're adding the service to the original webmap over https, the first thing to do is make sure that you're accessing the web app builder and web app over https.  Next, a browsers developer tools can provide more insight into why layers fail to load.  If you try to open the web app that fails with the developer tools open, can you check the Console tab to see what errors, if any, are returned?


I find the developer tools with Chrome are the easiest to work with, and can be accessed by pressing F12 or going to the Settings > More tools > Developer Tools.

0 Kudos
Occasional Contributor III

I cannot guarantee Im not mixing, if I am, I fail to see where I would be...

Ive been using Fiddler.. and see nothing, but let me try with Chrome F12

Were you able to successfully get a prompt in WAB for the secure service (to obtain a token)?

0 Kudos
Occasional Contributor III

Okay, I have it working through AGOL, I see it through the Web App builder in Online..

progress!  But then I download it, add it to my IIS... and no prompt ??

But then I noticed.. I reload the webappViewer in Online.. and No prompt there either...

ArcGIS Web Application

I am fully aware that HTTPS only can talk to HTTPS and not HTTP...

and Now I went back to the Web MAP, and now not able to add…

it gives me this...THIS.png

Ghosts I tell ya!

0 Kudos
Occasional Contributor III

Side note, I thought about the Cert being the issue, and having a hell of a time with Comodo obtaining one in a timely manner...

I fear that this is the root of my problem.

0 Kudos
by Esri Contributor
Esri Contributor

By test, I can't add the service into mapviewer of AGOL or Portal. I should be certificate issue. When I try to add this service into mapviewer, Chrome console shows the following error.

It indicates the https request to your server is blocked because the https request is insecure.

To make it more clear, you can paste the service url into a new Chrome tab, you can get the following screenshot.

I think maybe your server is using a self-signed certificate. You'd better use a signed certificate.

0 Kudos