Search Widget : Zoomscale configuration not working with geocoder

207
1
01-14-2021 08:17 AM
MélanieCambier
New Contributor

Hi everyone,

I have a problem with the zoomscale in the search widget. I'm using a custom geocoder service but the zoomscale I configure in the webappbuilder isn't taken into account. It zooms at 1:2000 whatever I do. I tried using the esriworldgeocoder and the same thing happens but this thime it's at 1:1000. There is no problem with feature layers, only with geocoders. (working on a 10.6 portal)

Maybe I can set something in the widget.js but I'm not fluent in javascript.

Any help would be much welcome.

Tags (2)
0 Kudos
1 Reply
ShelleySchott
Esri Contributor

@MélanieCambier , in the search widget you can set the located results zoom scale. By default the World Geolocator is set to 1:1000. In the Out of the Box Web AppBuilder, you can manually change this setting when editing the web app. 

image (4).png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This setting is saved in the json file of the web appbuilder so you should also be able to change the setting there.

Shelley Schott
Senior Consultant, Esri Australia
0 Kudos