Problem in production after Upgrade of Google Chrome to chrome 52.0.2743.82

3707
12
07-27-2016 01:07 AM
MalikAyaz
New Contributor II


Hello everyone,

We have Google Apps in our office so officially we can't block the upgrade of Google Chrome. Yesterday the Chrome was updated to version 52.0.2743.82, and our applications in production stopped because of it. We are using applciations based on web app builder using ArcGIS JS API 3.14. We do not have any other navigation allowed on our office desktops and tablets. Applications are working perfectly with version older versions like 51.0.2704.103.

We had similar problem with Chrome  51.0.2704.63, which was fixed with version is 51.0.2704.79. (reference Chrome 51 Issues with ArcGIS Online, Portal, or Custom Apps | Support Services Blog )

I have two questions :

1) Are we the only one who is facing this issue?

2) What are the porsible solutions?

Thanks a lot

Ayyaz MAHMOOD PARACHA

0 Kudos
12 Replies
BillFox
MVP Frequent Contributor

Reference: Currently using Portal for ArcGIS v10.3.1

0 Kudos
BillFox
MVP Frequent Contributor

Initial support cannot reproduce this error using Portal 10.4.1

Checking to see if it is a Portal 10.3.1 issue

0 Kudos
ayyazMahmood
New Contributor

Hello everyone,

Sorry for being late. Finaly I was able to resolve our issue. Infact for us the application was being blocked when it tried to load an application. So I started my analysis and found that earlier in our config.json I was loading the widgets by their identities like:

  {

        "label": "Coordinate",

        "uri": "widgets/Coordinate/Widget",

        "position": {

          "bottom": 10

        },

        "id": "widgets/Coordinate/Widget_4",

        "positionRelativeTo": "map",

        "name": "Coordinate"      },

Now I have to specify the location of config.json of each widget like:

  {

        "label": "Coordinate",

        "uri": "widgets/Coordinate/Widget",

        "position": {

          "bottom": 10

        },

        "id": "widgets/Coordinate/Widget_4",

        "positionRelativeTo": "map",

        "name": "Coordinate",

"config": "widgets/Coordinate/config.json"

      },

This resolved our issue.

Hope it will help someone else