Print widget issues

01-30-2023 12:40 PM
New Contributor III

Our applications are on Portal enterprise and the print widget on them was configured and working just fine, but now when the client tries to print, they get an error. I must mention that I tried to print using the print widget with the app opened on Chrome and the widget did not work but when I tried it on Firefox it did created a pdf.  

Has anyone experienced the same situation and how can it be fixed.

This is the error



0 Kudos
2 Replies
Occasional Contributor III

Unfortunately I don't have a solution but I can report the problems I am seeing with the AGOL-version of the Web AppBuilder print widget. Perhaps this can help you troubleshoot.

- When the web map includes map services that are hosted by external organizations I see the same error as you. If I turn those external map services OFF the printing works. In your case, it might be related to the source of the layer(s) in your map. Note that there are other threads that mention TLS/SSL Certificates as a potential source of the problem.

- Previously I was able to print using the "Advanced -> change Output spatial reference" to something other than default 102100 (WGS84 WM Aux Sphere). Now I see a similar error if I try to change the spatial reference when including tiled imagery services. Since our WAB is hosted in AGOL I am suspecting an update might have broken this. In your case, if you are changing the spatial reference perhaps that is causing the error.

- I tried all 3 major browsers with similar results (Chrome, FF, Edge).

In either case it is odd that it was working and now not, given you are working in the Enterprise WAB where you control the updates.

0 Kudos
New Contributor III

Thank you! 

0 Kudos