Login loop on deployed WAB Apps all of a sudden

2132
14
12-14-2021 10:15 AM
Rayn
by
New Contributor II

Hello all, 

We recently upgraded our enterprise from 10.9 to 10.9.1 and I'm not sure if this is related but now all of my server deployed WAB Apps are stuck in a login loop (anything accessed through the portal is totally fine).   I initially thought this might be due to using older version of WAB to build them so I updated my WAB to 2.21 (i tried 2.22 but had issues with the install).    However, any new Apps I create in 2.21 now request an additional login for the web map item.  I have recreated and reregistered the WAB developer application on my portal but this doesn't help.  

 

Any Ideas?

0 Kudos
14 Replies
fatinorain
New Contributor

Hi Michael, I faced the same problem and I have tried your solution  to overcome the problem by changing the JS API version in env and adding the appID, unfortunately it seems not working out for some widget.  Currently, I deployed the application in ArcGIS Enterprise 10.9 with WAB 2.24. 

 

What I meant by some widget is that when i try to click on other Widget such as NearMe, Bookmarks, Legend or Layer List widgets, it shows no sign in prompt but when I clicked on  Screening Widget, the prompt sign in will pop up. When I clicked on Sign-in, it will shows Invalid Redirect.

layerlist.jpg

 this is when i clicked on Layer List widget, no sign-in prompt

screening.jpg

 but when i clicked on Screening widget, the prompt will pop up.

invalid redirect_uri.jpg

Does anyone have any ideas is it because of the Screening Widget or is it because of something else?

 

Thank you in advance everyone.

0 Kudos
MichaelLev
Occasional Contributor III

@WeiYing1 ,

Same endless loop occurs also to us. I use Web AppBuilder Developer Edition 2.22 to develop web apps with custom widgets, and as I use ESRI JS API 4.18, I get endless login loop.

Explanation:

I am currently limited to ESRI js API 4.18, since SAML login is not working in Web AppBuilder Developer Edition with JS API versions newer than 4.18 [this issue has ESRI Bug Number BUG-000142159].

We upgraded the neterprise server to 10.9.1, and from that moment, JS API 4.18 enter endless login loops (newer API versions work ok, but as I explained above, we must currently use JS API 4.18)

I will appreciate a solution.  

 

0 Kudos
OliviaZ_Meowth
New Contributor II

Hi @MichaelLev , have you solve the issue with you? 

0 Kudos
MichaelLev
Occasional Contributor III

@Rayn , @OliviaZ_Meowth 

Sorry for the delay.

Problem is solved - Last 4.* js Api versions require that "AppId" in the main config.json file will not be empty string, but the real AppId of the WAB application in the portal. 

The problem occurred since pressing the download button in the WAB Developer Edition in order to create the zip file, automatically empties the AppId value in the config (in the zip file), so we must expand the zip, re-insert AppId value in the config, then use the app folders tree or re-create the zip manually.

This solution appears also in my question

Single Sign-On (SSO) stopped working after upgrading WAB from 2.17 to 2.20 due to bug in API 4.19 an... 

 

Cotter
by
New Contributor II

I ran into the same issue using 3.22 version of the JavaScript API and WebApp Builder.  Updating the API version on the env.js page to the latest (3.39) fixed this for me.