Invalid App Import

491
3
03-12-2018 01:41 PM
FredrickWarzwick
New Contributor

Hello everyone, hoping to get some clarification as I feel completely lost at this point:

I have setup WAB Dev (the latest version) and have been able to connect to it in the browser - no problems here.

Then, I begin by Importing a working Web App from our organizational account - no problems here it comes in fine and adds itself to the list.

Then I download it as a zip file and unzip it. 

Now, apparently if I touch any of the code components in Atom, or make any changes to anything, whatsoever, if I re-zip it and try to "Import from computer" I receive the "Invalid App." dialogue box. 

Maybe I am misunderstanding how this is supposed to work, but any help is appreciated!

Thanks,

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Fredrick,

   You can not do an export > import > download > change > re-zip > re-import. Not really sure why you would. You have the app imported into WAB Dev then you make all your code changes there and when you are satisfied your download and unzip to your web server.

0 Kudos
JoelPerkins
New Contributor III

We're changing arcgis servers so I'm trying to download my apps from the old and import to the new server. Running into the same problems. 

0 Kudos
AndresCastillo
MVP Regular Contributor

I was trying to import a vendor's wab developer edition zipped app into my wab dev instance.

I got an invalid zip error.

I saw this article:
Problem: Unable to upload an application to Web AppBuilder for ArcGIS (Developer Edition) 

0 Kudos