How to force Web AppBuilder to use HTTP (not HTTPS)?

2216
3
11-27-2016 06:52 PM
StephenLead
Regular Contributor III

I have an out-of-the-box instance of ArcGIS Web AppBuilder developer edition - the startup.bat file is unmodified and includes the lines:

REM open the url in browser
START http://%FQDN%:%port%/%wabVirtualPath%
EXIT 0

However, when I start a new session on my PC, it runs as https://localhost:3344/webappbuilder - even if I forcibly change the URL to http:// it immediately reverts to https://

This is causing a problem when I try to access ArcGIS Server REST endpoints which are not served via https.

For example, when trying to add a sample layer via the Local Layer Widget I get an error message about insecure content:

https problem


I'm working in a corporate environment and don't have the option of serving my local layers via HTTPS, so I'd like to know whether it's possible to force Web AppBuilder to run on HTTP.

0 Kudos
3 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Stephen,


   Sure all you have to do is delete the signininfo.json in the server directory. And then restart WAB and use a http URL when you are asked for your portal url this time.

StephenLead
Regular Contributor III

Hi Robert,

Thanks for the response. However, I can't get it to work - WAB always starts in HTTPS mode.

I deleted signininfo.json and restarted WAB. I specified the HTTP portal URL, but when opening up the oAUTH page to allow authorisation, HTTPS was used.

After this, signininfo.json contains:

"portalUrl": "https://XXX.maps.arcgis.com",

and when I reopen "localhost:3344" it still redirects to https://localhost:3344/webappbuilder/ The end result is that there is no change - WAB still uses the HTTPS version of the URL.

Is there another place where I can specify whether to use HTTPS or not?

Thanks,

Steve

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Steve,

   Sounds like you have the "Allow access to the organization through HTTPS only." option checked for your organization.