Select to view content in your preferred language

Failed Query from Joined View with Query Widget

4222
23
10-26-2015 09:07 AM
MarieCline_Delgado
Occasional Contributor

I have a view joined with a feature class (one-to-one).  I have set up a query/filter in the Web App builder from the feature class to search the joined view data but the query fails. 

What reasons could cause this query to fail?  Can I query joined data? 

Thank you!

0 Kudos
23 Replies
MarieCline_Delgado
Occasional Contributor

Is this what you mean?

0 Kudos
RobertScheitlin__GISP
MVP Emeritus

Marie,

   I need to see the text that is submitted for the where portion of the request indicated in my picture.

(i.e. yourURL/query?f=fjson&returnGeometry=true&......&where=_______?

Example.jpg

0 Kudos
MarieCline_Delgado
Occasional Contributor

Sending both query texts just in case

0 Kudos
RobertScheitlin__GISP
MVP Emeritus

Marie,

   Unfortunately those are the responses and not the requests that I need to see. Right click on the line I indicated and choose "copy link address", that will be what I need to see.

0 Kudos
MarieCline_Delgado
Occasional Contributor
0 Kudos
RobertScheitlin__GISP
MVP Emeritus

Marie,

   So based on that url you are doing a query based on the map extent and returning these fields:

outFields=OBJECTID_1,OBJECTID,AreaSqMile,AreaAcres,Enforce_Of,Officer_Ph,CE_Office,Shape.STArea(),Shape.STLength(),CE_Officer_Email

The use of the Shape.STArea() and Shape.STLength() can cause problems do you needs these? If not remove these fields from your Query widget configuration and try your query again.

0 Kudos
MarieCline_Delgado
Occasional Contributor

Odd.  Those fields are not from the layer I'm querying.  They are fields in a different layer, and the Shape.STArea() and Shape.STLength() fields are disabled from that layer. 

0 Kudos
RobertScheitlin__GISP
MVP Emeritus

Marie,

   OK that means that I choose the wrong line in the network tab. Can you look at the urls in the requests and find the proper one based on the layer you are searching and then send me that url?

0 Kudos
MarieCline_Delgado
Occasional Contributor

Robert,

I am having a little trouble finding the right request this time.  There isn't a query request like there previously was.  Maybe I'm doing something wrong. 

This URL could possibly be the one we are looking for; it mentions the correct layer and field - https://maps.cstx.gov/cstx/rest/services/Rental_Registration/MapServer/0/generateRenderer?classifica...

A screenshot of the requests (the red one is for the URL above):

0 Kudos
RobertScheitlin__GISP
MVP Emeritus

Marie,

   This is the error I get with that request.

{"error":{"code":500,"message":"Error handling service request : Could not find a service with the name 'MapServer/rental_registration' in the configured clusters. Service may be stopped or ArcGIS Server may not be running.","details":[]}}

And just trying the url to get to the map service results in the same error.

0 Kudos