Could not load created WFS with local webAppBuilder - problem with proxy

11-25-2020 09:59 AM
New Contributor


I installed ArcGIS server on WM on my computer. Then I published WFS on the server. I can connect to WFS in my local network and display it using eq. QGIS with:

I downloaded ArcGIS Web AppBuilder (Developer Edition) and followed all steps in the tutorial: 

URL: http://desktop-auvhne/webappbuilder and redirect URIs to http://desktop-auvhne and https://desktop-auvhne

I ran Web AppBuilder and created a simple app with AddData Widget


  1. If I try to add sample WFS it works and displays features correctly:
  2. If I try to add my WFS I see that request for getCapabilities and describeFeatureType works fine, but Post with GetFeature request fail - In Web AppBuilder for ArcGIS console i see: Argument error, options body

I've noticed in devtools that first requests looks like:

My requests uses proxy:  https://desktop-auvhne3:3344/proxy.js?
I tried to make a post request with getFeature via Postman without proxy and i get correct answer. 

How can I fix this problem and display my local WFS with my local app?

0 Kudos
0 Replies