Configure Screening Widget won't let me add layers

02-10-2020 08:29 AM
New Contributor

When I try to add the configure screening widget to my map, I try to click on the Add Layers button next to Analysis Layers and nothing happens. There is no error message, just nothing happens. I have feature layers added to my map, but I can't add them to my new widget. Other widgets work. 

6 Replies
New Contributor III

HI There

Did you figure out why this was happening? I am getting the same.


New Contributor III

I have this problem also in WAB Developer addition.  It was working (I thought in v2.16 Dev addition) but now I cannot add layers in the configuration window.  I have also tried it in v2.18 and the online AppBuilder.   I have tried with new apps and an app where it previously worked.  Any help would be appreciated.

Occasional Contributor

Similar issue for me, and I'm beginning to think it has something to do with my web map. When trying to configure the widget I can't add any layers, but when I make a new web map with only the layer I want to use for screening and then pull that map into the app the screening widget goes back to working fine. I really don't want to have to rebuild the web map but I'm beginning to get desperate... 😬

0 Kudos
New Contributor

I had a raster tile cache layer in my map and found that when I removed it, the screening widget worked. Not a great solution for me, since I need that layer in my map.

0 Kudos
New Contributor II

I had the Screening Widget completely configured with layers etc. and today I cannot use the Add Layers button. The layers are visible in the Download tab but cannot see them in the opening tab. The widget works fine but I want to add other layers and now cannot. Even when I attempt to create a new widget using the screening widget the Add Layers button does nothing. No error just nothing. Very strange. Possible corrupted web app i'm thinking.


New Contributor

I'm having this same issue. Has anyone found a solution?


0 Kudos