Cannot edit existing Query widget?? Just hangs ...

812
5
01-05-2017 06:23 AM
Brownschuh
Occasional Contributor

Trying to add a new query to an already established Query widget in an app our organization has built for our Assessors' department.  Basically we have an additional parcels map service we need to add to the query list.  However, when I try to edit the widget, it just hangs with the blue spinning, 'loading' circle (you can see a bit of the circle in the image I attached).  I'm unable to switch between the queries on the left hand side, nor can I click on and view any of the tabs; it's just frozen.  Thought it might be related to my AGOL account, but I ruled that out by having a colleague log in and attempt to edit the widget.  Also tried a few different browsers like Firefox, Chrome and IE, but they all produce the same results.  Well except for IE, that browser doesn't even load all of our layers ...

I should note that I am able to add a new Query widget and start from scratch (delete the old broken widget and rename the new) ...  but I need this existing one for a reference as I need to know what filters were put into place originally so I can mimic it with the new layer ...

Anyone else experienced this issue as of late?  Seems to be a newish bug as I edited this widget a few months ago with no problems ...

0 Kudos
5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Scott,

   Are you using AGOL WAB or WAB Dev edition?

0 Kudos
Brownschuh
Occasional Contributor

Ah sorry, should have clarified ... AGOL WAB.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

In that case your only option is to contact esri tech support.

0 Kudos
Brownschuh
Occasional Contributor

Figured that might be the case ... looks like I'll give ESRI a ring today.

0 Kudos
QunSun
by
New Contributor III

Scott,

Does Chrome show errors in Console or Network panel?

If you want to see the config.json of Query, you can download this app from AGOL. You can re-configure this widget by its config.json.

0 Kudos