Can't import web apps from WAB online OR upload ZIPs

06-26-2018 09:36 AM
New Contributor III

We’ve been unable to import or upload web apps into our Web AppBuilder Developer edition. I’ve been looking through posts about importing issues, but nothing seems to be quite right. We’re using the most updated version of WAB (2.8) in both Online and Developer and there aren’t any custom widgets. We get the same errors no matter which app we’re talking about. We had this issue with 2.7. I installed WAB 2.8, upgraded all our apps and deleted WAB 2.7, but that hasn’t solved the issue.

By way of a test case and demonstration, I created a super basic web map (one feature layer with only a dozen or so features). I then turned this into a web app using Web AppBuilder Online (just added one widget, a basic Filter) and tried to import it.

I first thought "checkVersion" had something to do with needing the most recent 2.8 version, but that's apparently not the case. The path that it seems to be following is odd: /rest/apps/checkVersion. This seems to imply there's a file called checkVersion which is in the apps folder of the rest folder. The only rest folder I can find in our WAB installation has a file called apps.js, but not a folder called apps. Am I reading this correctly?

I then tried downloading a ZIP of the basic web app and uploading it.

I found a variety to posts about corrupted zips and parsing errors, but nothing sounds quite right for our specific situation.

These are the same errors I was getting with my other more complex web apps. We’ve had issues with importing before back in March, but that involved a bug that had something to do with custom images in the web app. I don’t know if that bug still exists, but in any case this web app doesn’t have any images in it. We really need to be able to deploy these on our web server and using WAB Developer has been the best way to do this. Is this ringing a bell for anyone? I'm probably going to have to contact ESRI, but I figured it wouldn't hurt to post something first.

0 Replies