Can I use Web Appbuilder Dev Edition during a Free trial of ArcGis?

2785
14
Jump to solution
02-14-2017 05:16 AM
MariGerr
New Contributor II

I'm trying out ArcGis for a 60 day trial and would like to try the Web AppBuilder Dev Edition.   However when trying to install I get the infamous 

Error 400  Invalid redirect_url

I followed the install instructions here and troubleshooting here, with no luck.   I'm have node 6.9.5 installed.

I am a loss as to what is going on, so hoping for advice and also to check that it is not the trial account status that is causing the problem.

0 Kudos
14 Replies
RebeccaStrauch__GISP
MVP Emeritus

I know this is an old basic, but have you logged off your new ArcGIS Online account, then tried a reboot and tried it again?  Sometimes with our machines not crashing as often, this is an overlooked possible fix.

Also, I know some have nodejs start as a service on reboot.  I don't personally and instead just use the startup.bat in the folder of whichever WAB version I want to start up.  The first time I start it, it usually comes up blank or seems to lock. I shut down the window and restart the startup.bat and it will work.  I know if I went thru the process to run it the other way, it would probably resolve this, but most days I don't even get a chance to just into WAB, so only start the nodejs when I am ready.  I keep the /blogs/myAlaskaGIS/2016/03/09/web-appbuilder-developer-edition-customization-resource-list?sr=search... as much for me to find later, as well as helping anyone else that finds it helpful.

The PDF /blogs/wab/2015/05/01/installing-robert-s-enhanced-search-widget-for-the-web-appbuilder may also be of help.  The name makes it sound like it is just for the search widget, but it is actually a step by step guide for installing.  Although it is for a few versions back, it is still helpful.

Other than once again going carefully thru the steps on /blogs/myAlaskaGIS/2015/01/15/tips-and-observations-for-getting-web-appbuilder-developer-edition-ins...  , making sure you have the minimum requirements (and not installing on a server OS), spelling all items correctly....that's all I have to recommend.  After that, as Robert mentioned, might be a call to tech support.

edit: one more thing that might help, tagging dlaw-esristaff‌ who might be able to answer in case it is not allowed.  He may be tied up as the FedUC today (not sure if he is there or not)??

MariGerr
New Contributor II

Thanks for further suggestions and the detailed PDF for installing widgets.   The problem ended up being my machine name which was longer than 15 characters and was being cut off in the url.   I changed my machine name and changed settings on app and was able to launch now.

RebeccaStrauch__GISP
MVP Emeritus

The problem ended up being my machine name which was longer than 15 characters and was being cut off in the url.

Good to know.  I'll add that as a tip in the Tips blog page.  It may help someone else in the future.

KarynTareen
New Contributor III

Is the 15 character limit something that esri is going to fix?  soon?

0 Kudos
DerekLaw
Esri Esteemed Contributor

All,

Just to respond to Rebecca Strauch, GISP‌'s comment:

edit: one more thing that might help, tagging Derek Law who might be able to answer in case it is not allowed.

Yes, Web AppBuilder for ArcGIS Developer Edition should work with an ArcGIS Online trial account.

Hope this helps,