Attachment Viewer app

833
4
05-12-2020 07:44 AM
ThomasYork2
New Contributor II

I am creating an Attachment Viewer app using a published map service with the data being pulled from an SDE database. I have found articles stating you don't need to use hosted data and I can simply use the REST point from my published map service (ArcGIS 10.8). Then I see an article that references I need to use ArcPRO to publish my map service.

I created a web map that supports attachments and you can open the attachments in the pop-up I have configured. After I create the Attachment Viewer web app, it can't find any attachments. Under the 'General' tab inset map, I have the following - This application requires a layer that supports attachments and has 'supportsQueryAttachments' set to true. I select the web map I created, but still no attachments. 

Any thoughts or suggestions? Thank you in advance.

Tags (1)
4 Replies
JasonHerynk
New Contributor

I'm exeperiencing the same issue with our portal.  This application requires a layer that supports attachments and has 'supportsQueryAttachments' set to true.

PaulCone2
Occasional Contributor

Did you figure this out?  I had an existing web app -- the old version of attachment viewer -- and now it's broken.  It is pointing to a Survey123 _stakeholder service.  I suspect it broke after I made a change to the survey -- just changed the basemap and republished.  I tried created a new web app using the new Attachment Viewer template, but I still get this error.

0 Kudos
BrittanyBurson
Occasional Contributor III

Same here, using a survey _stakeholder service as well. Did you ever figure it out?

0 Kudos
PaulCone2
Occasional Contributor

I got the answer to this in an email exchange with ESRI.  "As far as I can determine, both the old and new/current versions of the Attachment Viewer app require the attachments to be on the feature table."

0 Kudos