Upgrade Dataset Tool in Pro 2.6.3 to UNv4 failing

580
7
01-08-2021 06:04 PM
geonexusjames
New Contributor II

I'm having an issue when attempting to upgrade a Electric UN to v4. Using Pro 2.6.3 and 'Update Dataset'. I've checked all features participating and none have any records with empty geometries. Getting this response: 

ERROR 999999: Something unexpected caused the tool to fail. Contact Esri Technical Support (http://esriurl.com/support) to Report a Bug, and refer to the error help for potential solutions or workarounds.
The operation was attempted on an empty geometry.
Failed to execute (UpgradeDataset).

7 Replies
DanPatterson
MVP Esteemed Contributor

The Check Geometry tool reported no issues?

You ensured all the prerequisites were met before attempting to upgrade first?

Utility network dataset administration—ArcGIS Pro | Documentation


... sort of retired...
geonexusjames
New Contributor II

Check geometry doesn't work on enterpise level. But I did backend ST checks. And yes, and prerequisites have been meet.

geonexusjames
New Contributor II

This appears to be a miss in logging on Esri's part: 

The operation was attempted on an empty geometry.

Yet the message doesn't identify which (if any) tables has the empty geometry. And really not sure which 1 within the UN table set would cause the issue:

geonexusjames_0-1610217279361.png

 

 

0 Kudos
JonDeRose
Esri Contributor

@geonexusjames I am going to look into this issue you reference with upgrade dataset.

You can identify empty geometry within the UN by reviewing the point errors table.  Features with empty geometry will generate an error with the ID =1 when the network topology is enabled.  These can also be visualized at the lower left-hand corner of the UN's Service Territory.   Once identified, you should then be able to use the Origin Network Source ID and Origin Global ID to identify the class and record that caused the error.

 

 

geonexusjames
New Contributor II

Hi Jonathan,

Thanks for the reply. This is good information. I've looked into the table's errortype and found 2 error types; 2 and 25. The description for 25 says 'stacked point'. Should I assume this is causing the issue? If so, will address these and attempt the Upgrade Dataset tool again.

Let me know.

geonexusjames_0-1610384197279.png

 

0 Kudos
JonDeRose
Esri Contributor

You should see errors with errortype = 1 with a message of: "The geometry for the network feature is empty." if these are preset in your UN.   

I tested a similar case on my end and was unable to reproduce this behavior.  I found that I was able to successfully upgrade a UN dataset from v3 to v4 on 2.6.3 with empty geometry records in one of my network classes. 

I would recommend reaching out to Support to get a new case created.  This may be data specific and Support would be able to help identify the issue for resolution or provide us with a reproducible case for further review.

Thanks,

Jon

geonexusjames
New Contributor II

To confirm, i do not see any records with that error type =1.

i will submit a request to support. thanks for the help.

0 Kudos