The Utility Network must be version 5

1751
6
12-17-2020 01:16 PM
MichaelHamsa
Occasional Contributor

Hello,

I'm trying to apply an asset package we received from one of our customers and I'm getting the error "The Utility Network must be version 5". I've just been back through and upgraded everything (ArcGIS Pro 2.7, Untools, and upgraded the Enterprise Geodatabase) but even after I stage a new utility network it looks like it's version 3. When I try to apply the asset package we received from our customer we get the error again.

The Utility Network must be version 5

Any ideas?

Thanks,

Mike...

0 Kudos
6 Replies
DanPatterson
MVP Esteemed Contributor

It is the "extra steps may be needed" in this link that always makes one wonder

Utility network dataset administration—ArcGIS Pro | Documentation


... sort of retired...
MelissaJarman
Esri Contributor

Not sure if this is your problem, but worth a try...

Starting at ArcGIS Pro 2.7 for enterprise geodatabases, the tools to create and upgrade a utility network look at the ArcGIS Pro and ArcGIS Enterprise versions to determine what version of the UN to create or upgrade. You won't be able to upgrade to UN version 5 unless you have a federated server of 10.9 for enterprise geodatabases. 

Check out the section on ArcGIS compatibility 

https://pro.arcgis.com/en/pro-app/latest/help/data/utility-network/utility-network-dataset-administr...

0 Kudos
JamesWright9
New Contributor III

How can we downgrade a package, we don't need v5. It appears this was the case since 2.7 creates an unsupported package.

0 Kudos
JamesWright9
New Contributor III

Just manually created an empty package at 2.6 and copied the tables in from the v5 2.7 package.  Working now

0 Kudos
James_Armstrong
Occasional Contributor

following up on this issue,  I am at ArcGIS Pro 2.8.3, ArcServer 10.9.  I download the UN water sample asset package and database.  The Asset Package is at model 4.1 and the Database network is at Model 5.  IN trying to upgrade the asset package, the tool does not work as there is not script associated with it.  IN trying to run the script from within a python file, I get errors that the module does not work.

I really want to use an work with the UN Utility network, but I no longer believe I have the knowledge or the resources to proceed.  It has been one thing after another, several chats and calls to ESRI tech support, and reading several posts, articles and such all with conflicting information.  I may need to wave the white flag.

Sorry,  just need to vent.

James

 

VishApte
Esri Contributor

Hi Mike,

You probably need to run Upgrade Asset Package tool to bring the version of the asset package to match the version of ArcGIS Pro. See https://solutions.arcgis.com/utilities/help/utility-network-automation/tool-reference/upgrade-asset-... 

Otherwise, temporarily downgrade your ArcGIS Pro to v2.5.x to match UN Asset Package version you have and build UN and publish, provided you have matching ArcGIS Enterprise (10.7 or later as per the table at https://pro.arcgis.com/en/pro-app/latest/help/data/utility-network/utility-network-dataset-administr... )

Cheers,

Vish

0 Kudos