Select to view content in your preferred language

Does Enable Network Topology Work in 2.4.2?

10-21-2019 08:30 PM
New Contributor


Is anyone else having issues when running Enable Network Topology (Errors Only) after the 2.4.2 release? I have gone through the process of staging a new network, applying the asset package and loading the data at least 5 times in the past 4 days. Everything completes successfully until I run Enable Network topology. Without fail, it fails. The error message doesn’t provide any useful information or hints at a possible cause. I’ve attached a screenshot of the error message I’m seeing. Any thoughts or suggestions on possible causes would be greatly appreciated.


3 Replies
Esri Regular Contributor

Hi Tyler,

Few questions:

  • Could you enable this dataset with a prior release?
  • What DBMS are you using?
  • Is the failure specific to this dataset (ie, have you tried others)?

If you share the asset package, I can take a look.

by Anonymous User
Not applicable

Hi Tyler,

I tried and it works fine.

I would like to ask you to check the UNtools version that should be v2.4.2. if not update the package.

I faced this type of problem previously and as a workaround, I tried following steps that went well for me.

  1. Close your ArcGIS Pro
  2. Restart your database service
  3. Restart your ArcGIS Server
  4. Re-open your project in ArcGIS Pro
  5. Re-run the GP Tool - Enanable Network Topology

Hope this will help you.

Good Luck!


0 Kudos
Esri Contributor

You probably have checked, but 

1. Is your EGDB connection set as branched version?

2. Is UN dataset registered as versioned?

3. Do all datasets have globalids?