Can't edit features after running Update Subnetwork

597
3
02-03-2022 07:52 AM
KyleGallagher16
New Contributor III

I am making some minor vertice updates to electric lines from a UN feature service in Pro 2.6.7 and then running Update Subnetwork on a specific Subnetwork Name to ensure end-to-end connectivity. However, after running the tool if I want to move on to the next subnetwork to make edits I am getting the following error:

Modify vertices failed. Layer is not editable. Review errors in the Status dialog or in List by Editing view of Contents pane.

KyleGallagher16_0-1643903535138.png

Going to the Status dialog it mentions that Dirty Areas and Electric Subnet Line are noneditable, and all other layers are editable with warnings (using enterprise geodatabase).

KyleGallagher16_1-1643903535149.png

My solution is to close and re-open Pro, but this is not sustainable. Thoughts on how to get around this issue?

Thanks!

Kyle

3 Replies
SSMIC3038
Occasional Contributor III

Just a shout out that I deal with the exact same problem, alot!

0 Kudos
GIS_Solutions
Occasional Contributor II

Hi,

Opening a new map, add date the feature class again. Try to use them without any symbology adjustments.
If it doesn't give an same error, apply your existing symbologies to your new map.

I had a similar problem and this is how I solved it.

0 Kudos
KyleGallagher16
New Contributor III

Would you say that takes about as long as closing Pro and reopening?

0 Kudos