Apply Asset Package (Comms domain) - Arcade Script error

1222
10
06-16-2021 10:04 AM
KyleGallagher16
New Contributor III

I recently downloaded the Comms v 1.1 UN and AP FGDBs, and have loaded to the AP some fiber features to CommunicationsLine, CommunicationsEdgeObject (fiber strands), and C_Associations (to relate the fibercables with strands). I am now attempting to run Apply Asset Package to load the data into the UN FGDB, but am getting the following error. None of the Naperville test data that came with either FGDB had the Object Count A fields populated so not sure why this would be an issue.

KyleGallagher16_0-1623862970580.png

Thanks!

0 Kudos
10 Replies
MikeMillerGIS
Esri Regular Contributor

What version of ArcGIS Pro and Untools are you using?

0 Kudos
KyleGallagher16
New Contributor III

Pro 2.8.0, untools 2.8.0.

0 Kudos
MikeMillerGIS
Esri Regular Contributor

Ok, did you happen to run Apply Asset Package twice?  The second time the attribute rules would be enabled and you will get this error.

0 Kudos
KyleGallagher16
New Contributor III

Yes, the first time it was ran with SCHEMA_ONLY and this error was generated:

KyleGallagher16_0-1623944818557.png

Is there a way to disable attribute rules to allow the AAP tool to run to completion? 

 

0 Kudos
MikeMillerGIS
Esri Regular Contributor

You will need to manually disable them on each class in the target database.

0 Kudos
KyleGallagher16
New Contributor III

Is that due to AAP being ran against a FGDB and not an enterprise GDB? I ask because I don't see Attribute Rules anywhere in the AAP documentation. That seems like a lot of steps to take just to make it work. Would we need to disable topology and attribute rules every time we want to use AAP?

0 Kudos
MikeMillerGIS
Esri Regular Contributor
If you run Apply Asset Package to a fresh UN, you do not need to do this. If you run Apply Asset Package schema only, then this creates the entire schema, with all attribute rules enabled. If you run Apply Asset Package again, then it detects the schema is in place and only loads the data, but the attribute rules are enabled at this point. The easiest it just run Apply Asset Package or Asset Package to Geodatabase with schema and data. The tools disable the attribute rules to ensure the data is loaded.
0 Kudos
KyleGallagher16
New Contributor III

I ran AAP against a "fresh" UN, that being the untouched downloaded Naperville model. It got all the way until it was running Make Feature Layer and Updating Schema (step 3 of 11) and Pro crashed.

0 Kudos
MikeMillerGIS
Esri Regular Contributor

Did you run Apply Asset Package against the utility network in Communication_UtilityNetwork.gdb that is shipped with the solution?  If so, there is no need, that GDB was created via the Asset Package to Geodatabase tool prior to packaging.  It is a fully built utility network. 

If you want to create a new GDB and Utility Network with the data you added, then use the Asset Package to Geodatabase tool.  I would suggest reviewing the task highlighted below.  They will walk you through the process to set this up without the sample naperville data.

MikeMillerGIS_0-1624012051035.png