Word Report 'Bullets' format

316
5
10-12-2020 05:04 AM
ChristinaKimbrough
New Contributor II

Hello, I can't seem to find an answer here or in Microsoft Word help so here goes.

I have a multi-selection question and want the answers to be listed as bullets in the word report form. 

${graffiti_location | appearance: “bullets”}

This does 'list' the selection but as sequential numbers. One, we would like them as 'bullets' and if we can't get away from the numbers, it unfortunately runs through the whole report not starting the numbers again per section but continues from the last one... 

i.e. 

Graffiti locations:

1.

2.

3.

Damage locations:

4.

5.

6.

and so on. 

We have several in this one report. 

Can anyone offer any suggestions?

Thanks, Christina 

0 Kudos
5 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Christina,

Could you try to remove the space in front of the "bullets" in your syntax and see if that would work?

${graffiti_location | appearance:”bullets”}

The syntax could be sensitive to the space though.

0 Kudos
Survey123TfLAdmin
New Contributor

Hi Shwu-jing, 

Thank you for the follow up. I've removed the spaces and still the same in a preview PDF sample report and MS Word generated report. I've even tried in a blank word document (no table, headings etc.) with just this syntax and it is still the same. The default appears to be numbering. What syntax string can I use to list only the selection options per line (not with a comma) and without a check box?

I have tried: ${graffiti_location | selected:"back_panel"} Back panel but this lists all of them with check boxes. 

Thanks, 
Christina 

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Christina, 

Could you share your XLSForm and the feature report template you are using with me so that I can test it here?

You can mail them to me here if you don't want to share it publicly.

0 Kudos
ChristinaKimbrough
New Contributor II

Hi Shwu-jing,

I have emailed you the documents.

Thank you, Christina 

0 Kudos
gvanderwaal
New Contributor

I also had this issue.

As it turns out, what '| appearance: "bullets"' actually does is output the labels of the select_multiple using the first level of the default "current" multilevel list.

It does so regardless of what bullets are being used elsewhere in the document and even if no multilevel list is actually being used. In our case, the default current multilevel list is always one with sequential numbers, so the bullets appeared as sequential numbers, instead of bullets. It's likely this was the case with Christina as well.

gvanderwaal_0-1614806889428.png

The fix (Office 365 Word version 2101, build 13628.20448 Click-to-Run) is:

  1. Open the multilevel list dropdown (shown above)
  2. Click "Define New Multilevel List..." at the bottom of the menu
  3. Click the "Number style for this level:" dropdown
  4. Scroll down and select "Bullet, Solid Circle:" (or any desired bullet type)
  5. Click OK

However, you're not done - the select_multiple will now output as bullets, but the bullets will ignore the surrounding formatting and use whatever is specified in the "Normal" style. So in our case, despite the whole .docx being in Arial 10, the bullets would be in Calibri (Body) 11 until the font/font size/paragraph spacing was changed in Normal.

If this was the way this feature was intended to work I wish it had been documented better.

0 Kudos