When the user saves a survey as a draft/outbox and refreshes the inbox it creates a redundant duplicate task from the draft/outbox and inbox.

873
4
02-02-2023 02:37 AM
by Anonymous User
Not applicable

When the user saves a survey as a draft/outbox and refreshes the inbox it creates a redundant duplicate task from the draft/outbox and inbox.
Users will see the survey in the draft/outbox, but also see a new survey in the inbox, for the same task, this causes an issue when the user completed both the inbox and draft/outbox survey for the same task.

Is it possible that when a user clicks the refresh button in their inbox, the task will not be populated because it is already in the draft or outbox folder?

If I use a query expression with the status field set to complete, the inbox will not be populated. However, because the status is not yet complete at the time of the refresh, it will reappear in the inbox.

Thank you.

0 Kudos
4 Replies
josevaldes1
Occasional Contributor

HI. The new versions are supposed to detect this situation. I have the same problem but when using in portal and a feature in a microsoft sql. If i use a hosted feature the app detect the situation and  does not bring the record in the inbox and shows a message that is in another of the folders. i create a ticket but still waiting for resolution.

0 Kudos
by Anonymous User
Not applicable

Hi josevaldes,

Thank you for your reply.

I am using 3.16.114 version. That is the latest version i believe, unfortunately its still not solving my issue. 

0 Kudos
josevaldes1
Occasional Contributor

Hi , i tested with 3.17.58 and the behavior continue. IMPORTANT: It happens whit my surveys that read a feature that is not hosted they are in a microsoft sql. 

I have a survey that use a hosted feature and if i have a record in draft and got to inbox and refresh , the inbox does not bring the record. 

0 Kudos
josevaldes1
Occasional Contributor

UPDATE:
I create a survey with connect and published to Enterprise Portal. Download the created feature(hosted). Copy to my local sql. Publish to Enterprise.
Create a survey with submission url to the sql feature. Open one record form inbox, put in draft and refresh the inbox. The survey makes the warning that i have the record in draft. So it works. The difference that i detect is with the globalid column. When the survey connect created the feature, the globalid is with lower 'g', but if a create a new feature in sql and add the globalid is created with capital 'G'. Is possible for the survey system thinks they are different? Can you tests this situation?

0 Kudos