What does red italic text mean when using a custom URL to populate a question?

195
3
Jump to solution
11-13-2019 04:02 AM
JamieLambert
Occasional Contributor III

Hi,

I have a custom URL to launch a survey and pass the area of interest and site name. I have the same process for another survey and have no issues. In this case however, the AOI is passed without issue, but the site name comes across as red italic text. When i submit the survey this text is not written to the record in the hosted feature.

I am also using the site name for some pulldata functions that are not running. If i manually select the site name, it all works fine.

My question is; what does it mean when you get red italic text when using a custom URL (see below)? For example, I think blue text indicates a calculation.

Thanks, Jamie

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Philip-Wilson
Esri Notable Contributor

Hi Jamie,

It means you have passed in an invalid value. I see as you are using a select one for this question, the value passed in via the URL is not a value in the choice list for that question. The value passed in needs to match the value in the name column of the choice, not the value in the label column.

Phil.

View solution in original post

3 Replies
Philip-Wilson
Esri Notable Contributor

Hi Jamie,

It means you have passed in an invalid value. I see as you are using a select one for this question, the value passed in via the URL is not a value in the choice list for that question. The value passed in needs to match the value in the name column of the choice, not the value in the label column.

Phil.

JamieLambert
Occasional Contributor III

Thanks Phil!

The choice list was the clue i needed. The values in the list are fine (value passed matches the name field). I have a calculation that filters the choice list based on the type of inspection (routine, spot, etc.). I just need to update this to accommodate the changes I am currently making. When i remove this calculation it all works as expected. So my issue is with this and not the URL!

Thanks, Jamie.

0 Kudos
HélèneTouyéras
Occasional Contributor II

Good afternoon,

 

I had the same issue while reading the choice list from a CSV file.

My 'name' values were all VAT codes in numeric form, and were interpreted as numeric values >> considered invalid >> displayed red even though I picked them in the drop-down menu. :\

I temporarily solved by adding a dummy line in the CSV file with a text value in the 'name' column, to force the interpretation of those codes as text and not numbers. (qualilfying value with double-quotes did not help interpret the values as text).

I thought I would share this here, as the symptom is identical, and the solution different ;)

 

With kind regards,

 

Hélène.

0 Kudos