Username field type doesn't work with Inbox

29
1
05-13-2019 09:40 AM
Highlighted
New Contributor III

I have a Username field type followed by a note.  The 'name' of the Username field is  'user_nm'.  The note is named 'usernote' with a label that says "Username: ${user_nm}".  I'm using the android app.  when i select 'Collect' the usernote field displays a note correctly.  If i select Inbox and open up the survey from there the usernote field displays "Username:" and that is all.  It is just blank after the colon.

I am trying to get  the username to display properly so that I can try to create a "Where clause" for my inbox .  I have a field in my feature service that I populated with the usernames of the people that are assigned to each particular site.  None of the "where statements" that I have created work. I've tried using "Contains" statements and I've tried using "Like" statements and nothing works.  If I delete all other users in my "assigned_crew_userID" field, and just leave one username, then the where statement works correctly.  But I need each site to show up in multiple users inbox's. Currently, within the "assigned_crew_userID" field i have the usernames separated by a single space.

This post Help with Inbox?  explains more about my situation.  The two responses that I got were not very relevant.  Any help would be appreciated.

-Andy

Reply
0 Kudos
1 Reply
Highlighted
Esri Frequent Contributor

Hi Andrew,

What version of Connect and Field App are you using, and on what devices and OS version?

If you are using 3.3, we have a known bug with Inbox filter and using where clause query with username field. This has already been fixed in the 3.4 beta builds available on EAC for download and via Testflight. 

This was already reported in EAC forum here: https://earlyadopter.esri.com/project/forum/thread.html?cap=e69ef91f45744b98882c651f7b518eb7&forid={...

Please try out 3.4 beta and let us know if the Inbox where clause query you are trying to use is still not working?

Phil.

Reply
0 Kudos