Unable to send Survey123 to new feature class

10-18-2022 09:05 AM
New Contributor

I've been working to create a set surveys, all linked to a set of base points in FieldMaps. 

So far, here is what I've done:

  1. Wrote all surveys: Buried Channel, Transects, Reach-Wide, and Photos.
  2. I published all of my surveys and opened the automatically generated feature layers from AGOL into ArcGIS Pro
  3. Used the feature-to-feature tool to bring all layers into a single geodatabase. 
  4. Generated relationship classes for each of the survey point layers to the primary " Base Points" layer using a PointID (field I created to refer to my base points)
  5. Generated relationship classes for each of the tables using GlobalIds and Parent-global Ids
  6. Configured Pop-up with a hyperlink to each survey that should auto-fill the PointID (from fieldmaps into Survey123)
  7. Published my geodatabase as a web-map
  8. Republished all of the surveys using the submission URL I generated from the geodatabase feature layer

This worked for three out of four my surveys. The URL in my pop-up will not open the Transect form. It will open survey123, but then it just spins until it crashes. I have tried multiple devices and none of them work. When I open the form directly from the Survey123 App and manually enter the PointID, I am able to fill out my survey and submit to outbox, but the survey will not send. When it is trying to submit the pop-up/loading screen flashes through all of the related tables and layers, so it appears to be communicating with my feature layer. After trying to send for a few seconds, it stops with an error saying, "Operation Rolled Back." I set up the other three surveys exactly the same, so I am pretty stumped.

0 Kudos
2 Replies
Occasional Contributor III

WOW - you got creative with this one. I want to walk through this with you.

I'm DM you to see if we can set up a time after work.

0 Kudos
MVP Esteemed Contributor

Looks like you are using my trick so I hope you saw this post even though its dated now  https://community.esri.com/t5/arcgis-survey123-questions/mapping-with-survey123-within-a-polygon-or-...

It is way easier to download the GDB of each form and then simply copy paste into the master GDB.  Then you do not have to recreate all the 123 relates.  Much faster and more reliable.

My guess here is you missed copying something over for that form.  A related table, attachments table maybe, possibly domains.  Without seeing the form or URL I would start there.  I would suggest starting over really and use the copy paste method.

Your error almost looks like it does not like PointID.  Maybe it is a number or short text or something?

Hope that helps some

0 Kudos