Surveys Not Submitting Saving to OutBox

290
1
07-02-2020 08:14 AM
Chris_Anderson
Occasional Contributor

I am working on a project that will allow some agency biologists to use S123 during aerial surveys tracking Florida panthers. I can load the survey onto the iPad Pro, and use it without a problem. Because the biologists won't have access to a cell signal in the center of the Everglades, I have created a TPK file and added it to the iPad using the instructions found in Prepare basemaps for offline use ;I used iTunes to transfer the file. I can see the TPK file in the Geopoint question, so I know S123 can read it. The problem lies when I try to submit the survey. Nothing happens when I click "Send now" and "Save this survey to the Outbox". Something happened in the background when I upload the TPK file. Other surveys operate correctly. Thinking I messed-up the upload of the TPK file, I deleted the app, then reinstalled it, downloaded the panther survey,  opened it, and was able to submit a record. I then added the TPK file using iTunes, and tried the survey and ran into the previous problem. To see if the iPad Pro was the problem, I tried adding the survey and basemap onto an older iPad and obtained the same results before and after adding the TPK file.

I am attaching a copy of the survey.

Any help you can provide is greatly appreciated.

Chris Anderson

Florida Fish and Wildlife Conservation Commission

Fish and Wildlife Research Institute

Tags (1)
0 Kudos
1 Reply
ZacharySutherby
Esri Regular Contributor

Hello Chris, 

Thank you for passing along the XLSForm! I had tested in my ArcGIS Online organization with a test tpk and I was not able to reproduce the same behavior. 

I was testing in ArcGIS Survey123 3.10.323 (EAC build) on an IOS device. 

For the TPK was it created in ArcGIS Pro? If so is the file extension TPK or TPKX? If it is TPKX if you save it as a .TPK is the same behavior reproduced? 

Does the TPK use the ArcGIS Online | Bing Maps | Google Maps tiling scheme? 

I have attached my sample TPK for testing (you will likely need to search for Redlands, CA in the Geopoint's search bar)

When you hit send there is no error message correct? In Survey123 Field App on the MySurvey's page if you select your profile icon on the top right > Settings > Diagnostics > Enable logging. If you grab the logs when you try to submit a survey are there any error messages in the associated log file generated? 

Thank you, 

Zach 

Thank you,
Zach
0 Kudos