Survey123 with Java Script extensions is not working properly when accessed via Survey123 generated link

961
5
11-19-2019 02:00 PM
deleted-user-4fdfHeRNtD88
New Contributor

When trying to access a survey that uses Java Script extensions to pull data from an API and auto populate survey fields, users who are accessing the survey via a link generated by Survey123 are unable to use the extensions. No error messages or warnings are given, but the auto populated fields are left blank. If however, if they open up the Survey123 application and download the survey, the extensions work as expected.

A few notes:

  • All users are within my organization and survey is shared to the entire organization
  • Version 3.6 or newer of Survey123
  • Link generated is forcing users to take the survey in the Survey123 app and not a web form

Any ideas as to why this might be happening or if there is a workaround?

Thanks

0 Kudos
5 Replies
Philip-Wilson
Esri Notable Contributor

Hi Kyle,

Are the users signed in when attempting to complete the survey after it has been downloaded? If they are signed out when opening the survey the JS functions will not run.

Or is the survey share to Everyone (public) as well as Organization? JS functions will also not work if survey is shared publicly.

Regards,

Phil.

0 Kudos
deleted-user-4fdfHeRNtD88
New Contributor

Hello Phil,

I confirmed that users were properly logged in and that the survey was shared to my entire organization, but not publicly to everyone.

Some additional background: Once downloaded from within the Survey123 app, the extensions work great. Clicking on the link opens the downloaded survey and provides the auto generated data from the Java Script. However when the user clicks the link generated by Survey123 before downloading the survey in the app, a version of the survey is downloaded that does not allow for extensions. Even going back an access this version of the downloaded survey within Survey123 app does not contain extensions.

So while there is a work around of downloading the survey via the Survey123 app before using the link, this is certainly an major inconvenience when sharing a survey with a large organization where everyone is not an expert in ESRI products.

Thanks,

Kyle

0 Kudos
BrettStokes
Esri Contributor

Hi Kyle,

I've been able to reproduce this issue. The .iteminfo file (which accompanies the downloaded survey) does not contain the Organisation ID when the survey is downloaded by a user who isn't the survey owner via the shared link. This OrgID is needed to enable the JS function to execute. 

Since custom pulldata JS functions are still beta functionality, I encourage you to submit an enhancement request via Esri Support. You will get an enhancement number for your records and similar requests from other customers can then be attached. This helps us assess demand for the enhancement and prioritize it accordingly.

Best regards,

Brett

0 Kudos
Jack_Lim
New Contributor III

Hi Phil,

I currently having the same/similar issue. I created a Survey123 Form for web browser which contains JS functions, and I have to share with groups. However the JS functions not working for the group members. But it works on my side. Any idea it's works on my end and doesn't works for the others. Is that because I create or own it? How am I able the share the the form with JS functions to other group?

Thanks

Jack

Tags (1)
0 Kudos
BrianNemec2
New Contributor II

I'm not sure if the issue I'm having is the same but it sounds similar.  My issue is that when my users are directly going into Survey123 and submitting a survey everything works but when I use a link from ArcGIS Explorer to open Survey123 and pass field values into some of the Surveys fields not all of them are coming over.  

we thoroughly tested the Explorer to Survey123 links last Friday Nov 15th everything worked and came across.  We did not touch or modify anything in Explorer or Survey123 and tried it again today and are seeing this unusual behavior.  We tried troubleshooting this for hours with no luck.  The only change between Friday and today that we know about is the update to AGOL that was done on November 19th.  I'm beginning to think something broke with this update.

Kyle,  does that sound like the behavior your experiencing as well?

0 Kudos