Survey123 webform generation error following update to version 3.13.249

829
7
Jump to solution
11-18-2021 03:06 PM
EmilyMcLeanACTGOV
Occasional Contributor

Hi, 

I have been experiencing an issue where when I publish a specific survey from Survey123 Connect (I've tested both to AGOL and ArcGIS Enterprise) there is an error in generating the webform and so I'm unable to open the survey within a browser. I'm able to successfully open it within the app. I've had a look in the web form file in the survey folder and it just contains the following: 

{
"error": {
"code": -1,
"details": [],
"message": "{}"
},
"success": false
}

I tested publishing one of the template surveys as well and that has generated the webform successfully, so it looks like the issue is specific to this survey. I saw that there was a similar issue following the September update, and am wondering if it is caused by a specific question type that I have included in my survey? 

Any suggestions would be appreciated! 

Thanks!

Emily
0 Kudos
2 Solutions

Accepted Solutions
EmilyMcLeanACTGOV
Occasional Contributor

For everyone experiencing the same issue the following post has provided an update that the issue has been listed as a bug: 

BUG-000144749 - Survey with external select published from Survey123 Connect cannot be accessed in web app returning an error "This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file."

They have advised that you are able to workaround the issue by using select_one_from_file as an alternative to external selects. 

Thanks,

Emily

View solution in original post

0 Kudos
Kanin
by Esri Contributor
Esri Contributor

Hi all,

Based on this blog: What's new in ArcGIS Survey123 (December 2021) - Esri Community

BUG-000144749 Survey with external selects published from ArcGIS Survey123 Connect cannot be accessed in the web app, and returns the following error message, "This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file."

The defect above has been fixed in the December 2021 release of Survey123 website. Please do see if the issues has been resolved in your survey forms.

Best regards,
Kanin 

If this answer solved your question, please mark it as "Accept as Solution" to help others who have the same question.

View solution in original post

7 Replies
HaroldHerrera1
Occasional Contributor

Update: Republish Survey123 connect in version 3.11 and works fine...

Philip-Wilson
Esri Notable Contributor

Hi @EmilyMcLeanACTGOV , @HaroldHerrera1,

Are you able to provide a copy of your XLSForm so we can reproduce the error you are seeing, also attach any media files from the media folder if they are used in the survey.

If you are unable to share publicly, please send me private message with attachments.

Regards,

Phil.

0 Kudos
EmilyMcLeanACTGOV
Occasional Contributor

Hi @Philip-Wilson 

Thanks for following up on this. I have sent you a DM with the requested files. 

Cheers, 

Emily
0 Kudos
EmilyMcLeanACTGOV
Occasional Contributor

For everyone that is experiencing the same issue I have found an update in the following post that it has been logged as a bug: 

BUG-000144749 - Survey with external select published from Survey123 Connect cannot be accessed in web app returning an error "This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file."

They have listed a work around as using Select_one_from_file which is apparently not impacted by the issue. 

Emily
EmilyMcLeanACTGOV
Occasional Contributor

For everyone experiencing the same issue the following post has provided an update that the issue has been listed as a bug: 

BUG-000144749 - Survey with external select published from Survey123 Connect cannot be accessed in web app returning an error "This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file."

They have advised that you are able to workaround the issue by using select_one_from_file as an alternative to external selects. 

Thanks,

Emily
0 Kudos
Kanin
by Esri Contributor
Esri Contributor

Hi all,

Based on this blog: What's new in ArcGIS Survey123 (December 2021) - Esri Community

BUG-000144749 Survey with external selects published from ArcGIS Survey123 Connect cannot be accessed in the web app, and returns the following error message, "This survey cannot be accessed in the web app. Please contact the survey owner to republish the survey with 'Create web form' enabled. Error: Missing .webform file."

The defect above has been fixed in the December 2021 release of Survey123 website. Please do see if the issues has been resolved in your survey forms.

Best regards,
Kanin 

If this answer solved your question, please mark it as "Accept as Solution" to help others who have the same question.