Survey123 URL XY center issue with commas, geopoints, geoshapes

305
2
05-07-2020 01:15 PM
JeffHill
New Contributor II

I am trying to pass many attributes from a web service to survey form, including spatial data.

1: I want to pass the center point to populate a geopoint location. When I test the URL I configured the center parameter passes as such: &center=35.431279121%2C-86.210751558

But nothing populates in the geopoint question from this. 

If I remove (manually) the %2C and replace with a comma, it works fine. Is this a known limitation when using the web form for survey123? 

2: I actually would prefer to replace my geopoint question with a geoshape question but I run into several issues:

If there are many vertices the url length is a problem and I get a 494 error. 

Passing the vertices can't be a "center" parameter, but is the answer to a field/question instead so I get the following:

field:prescshape=35.4955258942163%20-87.5681752757275%3B35.4950675536209%20-87.5676845847538%3B35.4947421087082%20-87.5669107375285%3B35.4946169958997%20-87.566460080437%3B35.494379472624%20-87.5664859347469

I tried here doing the same manual fix of removing %20 and replace with comma, plus remove %3B and replace with semicolon, but the polygon does not show up in the geoshape question.

A solution to either problem would be great! Or if this is a known limitation of the web form that is ok too. 

0 Kudos
2 Replies
BrettStokes
Esri Contributor

Hi Jeff,

Did you end up finding a solution to either of these issues? Please post on the forum if you did.

Thanks,

Brett

0 Kudos
JeffHill
New Contributor II

Hi Brett,

I did not find a solution to either problem, but the point parameter started to pass. I may have had to remove a space in it. I do not know much about how URLs work so I can't really say much else about this issue.