Select to view content in your preferred language

Survey123 Select One Cascade Selects in Repeat not working in browser with jr:choice-name

03-15-2023 12:43 PM
New Contributor III

Hi @JamesTedrick and @IsmaelChivite 

I am having a bit of an issue that I feel is likely a bug as it works correctly in the Survey123 Field App, but not in the Survey123 Web App. 

I have a repeat with cascading select where I calculate the jr:choice_name for each record in the repeat and then I tied all records outside of the repeat with a join calculation. 

Please see attachment SurveyDesign.PNG

${CountyFilter} question has three options in the select one list (County, Region, Statewide)

${CountyList} question has a subset of choices based on my choice_filter

${CountyInput} question prints the label of that choice selected in the ${CountyList} question

${County} question is outside of the repeat and joins all ${CountyInput} answers from the repeat together by using the join(", ",${CountyInput}) calculation. 

The issue that I am having is the ${CountyInput} does not actually calculate the jr:choice-name if it is anything other than my first selected choice in my ${CountyFilter} question. For example if I select Region the first time, but add a record and select County the second time it does not print my ${ChoiceList} selection label for that second record. But if add a third record and choose Region again in my first select one question and then proceed to choose my county in my second select one question. Then it prints it again. 

Please see attachments Browser_Repeat1.PNG, Browser_Repeat2.PNG, and Browser_Repeat3.PNG

You can see it skipped my second record in my join calculation because my jr:choice name isn't calculating on my second repeat. Again this only happens in the web browser and not the field app. The issue is I would like this to be an anonymous survey so I need to have it for the browser only. 

I tried to figure out if position(...) calculation and Indexing may help, but I was struggling to figure it out. Any suggestions or documents you could send me that may help with my problem? 


Thanks in advance!

5 Replies
New Contributor III

I forgot to mention I am using Survey123 Connect version 3.17.54 for design.

0 Kudos
New Contributor III

I discovered the issue after some extensive testing on my end. I believe this is a bug since this form worked correctly in the Survey123 field app, but not the browser. 

${CountyFilter} question had the minimal appearance.

${CountyList} question  had an autocomplete appearance.

The autocomplete appearance seemed to be the culprit. As soon as I changed the appearance from autocomplete to minimal and published my form it worked correctly in the browser. ${CountyInput} question was able to print the label of that choice selected in the ${CountyList} question within the repeat even if the ${CountyFilter} selection changed between records. 

This is not ideal since my list of choices are quite lengthy. It would be nice if the users wouldn't have to scroll through the whole list to find their choice, but just type a few letters to simplify the list using the autocomplete appearance.

ESRI is this fixable for the browser web application? 

New Contributor II

Thanks, Trisha! I have the same issue when using jr:choice-name within a repeat to get the label from an external choice list. Using the minimal appearance fixed it (thank you for that solution!), but like you, I have a very long list of choices (100s of organization names) and it will be more challenging for folks to fill it out in the browser without autocomplete. This does appear to be a bug and it would be great if it could get fixed!

0 Kudos
New Contributor III

I did get a bug assigned after talking with ESRI support in case you want to follow: BUG-000156854. 

New Contributor III

I spent over 3 hours trying to figure this same problem out, until I found your post. Hopefully they will get it fixed soon ! Thanks!

0 Kudos