Survey123 Public ArcGIS Server FeatureServer

247
2
01-09-2020 01:15 PM
GreggRoemhildt
Occasional Contributor III

Hi - I'm working with a public feature server that I have added to ArcGIS Online.

I did not store credentials, because the feature layer is public. Survey123 appears to be still trying to grab/send a token though to arcgis server and I see this error in the logs:

<10>1 2020-01-09T20:40:33Z WSBLAPTOP-171I Survey123ConnectforArcGIS 24924 - [AppStudio@11205 category="PortalRequest" function="onFailed" filename="PortalRequest.qml" line="100"] PortalRequest: PortalRequest failed: url https://utility.arcgis.com/usrsvcs/servers/1b984512aa2c405b881f5ded0764e288/rest/services/wsb/materials_testing_inspections_webmap/FeatureServer error {
  "code": 498,
  "details": [],
  "message": "Invalid Token"
}
<15>1 2020-01-09T20:40:33Z WSBLAPTOP-171I Survey123ConnectforArcGIS 24924 - [AppStudio@11205 category="qml" function="onFail" filename="PublishServiceCheck.qml" line="66"] qml: Check error: {
  "code": 498,
  "details": [],
  "message": "Invalid Token"
}
<15>1 2020-01-09T20:40:33Z WSBLAPTOP-171I Survey123ConnectforArcGIS 24924 - [AppStudio@11205 category="qml" function="onChecked" filename="PublishServiceCheck.qml" line="62"] qml: Check result: {
  "compatible": false,
  "reason": "Request error 498 Invalid Token",
  "newFields": null
}

Probably because there is no token required for this feature service. Is this a bug or am I doing something wrong? Should this work?

0 Kudos
2 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Gregg,

Survey123 does not work with publicly shared standalone ArcGIS Server feature services; the feature service must be secured and registered with ArcGIS Online storing credentials. This is so that a service endpoint is created in the ArcGIS Online system (normally seen as https://utility.arcgis.com/...) and is secured using the same identity controls as the ArcGIS Online system.

GreggRoemhildt
Occasional Contributor III

Thanks James - that is useful information to know.

The reason I have it as "public" is I am creating a development service on my local network, and using the hosts file on my system to create a simulation of our production environment, this way I can test a survey easily without modifying production data. I guess this will not work since survey123 has to go through arcgis online's utility proxy.

0 Kudos