Survey123 feature layer not working for Offline Map Areas

531
2
08-07-2019 02:26 PM
IsidroBarela
New Contributor

I have a survey in Survey 123 where I have added the feature layer into a web map. This operation was working fine up until yesterday when I tried to download an area in Collector or create a offline map area in ArcGIS Online; this operation fails in both applications. I know it has something to do with the Survey 123 feature layer, by process of elimination the offline services work when the Survey 123 created feature layer was not in the web map. Also, all the layers are set up for offline ("sync") use. I can't figure out why it suddenly stopped working, I even tried recreating the survey but no luck. If you have any suggestions I would greatly appreciate it! 

Thanks,

survey123 collector‌,collector download‌,survey123 feature,take offline‌, #display a map while offline

0 Kudos
2 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Isidro,

Could I ask that you open a support ticket with Esri on this?  

0 Kudos
MJBiazar
Esri Contributor

Hi @IsidroBarela,

 

I know this is an old post but in case anyone else is running into this issue, I'm posting this update here:

If you have a multiple choice question with Other option where question name and one of the choices share more than 31 characters, question/choice names (field names) will be truncated when trying to create an offline area since the maximum field length is 30 characters in SQLite database, which will create two fields with the same name which causes failure. 

In order to work around this issue, you can modify the schema in Survey123 website before publishing and rename the fields so that they have different names.

3.png

2.png

Similar issues may happen in other situations with Single Choice Grid questions so checking the attribute fields on the hosted feature layer in AGOL under Data tab will help identifying fields with names longer than 31 characters that may cause this issue.

1.png

 

Best,

MJ

0 Kudos