why Survey 123 is returning 'label' instead of 'name' for text data files

376
2
02-03-2021 02:08 AM
PaulG
by
New Contributor II

Hi there,

So I created some surveys using the desktop app and collected some data. However, when I download the data the column headers have the 'label' name for every instead of the name. This is only happening to text data type.

Consider the survey below:

typenamelabel
textQ201b_nameQ201b: Record the Name of the Place:  [ASK FOR NAME OF NEAREST PLACE AND RECORD NAME OF THE PLACE]
textQ205kOther (Specify:)
textQ209nOther (Specify:)

 

When I download the data, column names look like:

Q201b: Record the Name of the Place:  [ASK FOR NAME OF NEAREST PLACE AND RECORD NAME OF THE PLACE]Other (Specify:)Other (Specify:)

 

Instead of:

Q201b_nameQ205kQ209n

 

Any help is much Appreciated.

Paul

 

0 Kudos
2 Replies
BrettStokes
Esri Contributor

Hi Paul,

I can't reproduce this problem when publishing using 3.12 Connect to ArcGIS Online (exporting to SHP and File Geodatabase). Are you using ArcGIS Online or ArcGIS Enterprise? Also, what format are you exporting to (i assume you're exporting via the Survey123 website)?

Thanks,

Brett

0 Kudos
ADM48
by
New Contributor

I am having a similar issue.  I want the 'name' field to be used to populate the feature service, but instead the 'label' field is being added.  Am I misunderstanding the purpose of the 'name' field.   

I'm using ArcGIS Online.  I'm publishing the survey through Survey123 Connect. 

AdamMcKay4_0-1619187651265.png

Thanks