Survey123 Connect version 3.15 error- Can't find .xml

08-30-2022 08:50 AM
New Contributor III

I just started using version 3.15 Survey123 Connect. I keep getting various errors that the *xlsx.xml doesn't exist. I tried it on 2 different computers for version 3.15. The issue pops up when I edit current forms and when I create new forms. I have not moved any files.  Any ideas what the issue might be? Thanks.

1st Example:


2nd Example:




6 Replies
Occasional Contributor

Same here.

0 Kudos
Esri Regular Contributor

Hello @Alena @TanGnar

This issue looks to be due to extra bloat in XLSFroms. For example if there are a number of extra columns or rows in the XLSForm that aren't used but are making the file size larger may cause this conversion error. 

If you delete any extra columns on all the worksheets in the XLSForm to reduce the file size that should help resolve the issue. 

Thank you,
New Contributor

Hi @ZacharySutherby 

I have a client and several colleagues from the organization present with the same inconvenience, what you indicate was applied but the error still persists, it was tested in several versions 3.15 and 3.16, it still presents the error.

To know if they already reported it as a system error, you don't know if there is another method to apply it.

0 Kudos
Esri Regular Contributor

Hello @GaryRodriguez

Is the behavior consistently happening (every form update) with one or more surveys, or does the error periodically happen on form update? 

If possible may I ask for a copy of the XLSForm that's encountering the behavior for testing on our end? Feel free to send it to and I can take a look into it.

Thank you,
0 Kudos
Occasional Contributor II

Hello @ZacharySutherby I have deleted extra columns and it is still happening. For some time it has happened periodically and then resolved when I tried later. But this time it is not coming around. 

Any full solution to this?



0 Kudos
Esri Regular Contributor

Hello @JessicaJThompson

We do have a fix for this issue coming with our 3.17 release later this month. For the time being if you change your API URL in Connect to that environment has the fix on it at this time. 

To change the API URL in Connect select the profile icon or hamburger on the top right and select Settings. Select the Services and add the qa after survey123 in the URL: 



It is recommended that after Survey123 3.17 releases you switch the API URL back to the original

Thank you,