Survey123 Arabic/Farsi

144
2
05-11-2021 05:03 AM
SwathiIyengar
New Contributor II

Hi, 

We've deployed some surveys in Arabic/Farsi recently and had a few issues come up during implementation.

1) Multiline textboxes do not seem to work. The character limits decrease as text is typed in Arabic/Farsi, so it seems like something is registering, but nothing appears in Survey123. The survey behaves normally when text is typed into a normal text field.

2) Arabic/Farsi labels are not shown right to left as formatted in the survey form. Is there a way to fix this?

Screenshot 1 and survey form included for reference. 

Thanks!

0 Kudos
2 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Swathilyengar,

 

Could you provide more information regarding the multiline text input for Farsi language?

1. Did the issue occur only on Android phone with the Farsi input? What model of the Android phone is used?

2. What version of Connect did you use to piublish this survey? Did you have problem to type Farsi in Connecy and field app on Windows or on the web form?

3. Did the same multiline text input work on iOS device?

 

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Swathilyengar,

I was able to reproduce your issue and this issue seems to start with 3.12 version and when you switch from english to a right to left language. I had entered an internal issue for this and also encourage you to submit this issue as a bug via Esri Support. Our Support team will assign an official bug number for your records. This number can be used to search for and subscribe to the bug on the Esri Support site. If the issue is reported by other customers it will be attached to the same bug report, which helps us assess the impact of the issue and prioritize it accordingly.

0 Kudos