Survey allowed to be submitted when required questions are not answered

1809
11
04-08-2019 08:14 AM
ForestSwaciak
New Contributor II

I have been working on a survey and have been having a problem, when completed in the Survey123 app only, where it can be submitted without answering questions that have been marked to be required. 

If the survey is complete with Survey123 Connect, the expected error messages pop up when attempting to submit so this issue is only apparent when completing a survey within the mobile and desktop app.  

I tried looking at all of the questions having these issues and the most common relationship that these specific questions have with each other. They all have formulas written in the "Relevant" column that were made to hide questions when specific selections have been made. 

I deleted one of these Relevant fields and it did work by giving an error message when attempting to submit without this specific question answered. However, these relevant fields are needed for the survey so I still need them to be present. 

Is anyone aware of this issue and is it a known bug? 

Any help would be greatly appreciated to find a workaround to this problem. 

Thanks in Advanced. 

EDIT: When using an older version of the  Survey123 mobile app (3.0.149), the expected validation messages did appear requiring entry for the relevant required fields. Therefore, we think this is a bug with the latest release of the Survey123 mobile app.  

relevant‌ survey123app‌

Tags (2)
0 Kudos
11 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Forest,

Could you share the xls file of the Survey?

ForestSwaciak
New Contributor II

James,

Will do.  This survey was created for a state agency so I would rather email it to you directly rather than posting it publicly as long as you are comfortable sharing your email address. Thank you for willing to help with this, hopefully we can determine a resolution. 

0 Kudos
DougBrowning
MVP Notable Contributor

Does the field have a relevant on it?  Phil and I traced down this error already.  

When a field has a relevant and a constraint or required it is not triggering the message sometimes. 

For me fields will no relevant trigger a message when going to the next repeat.  When a field has a relevant (and not showing on initial repeat load) it will not check the constraint and message until the form is submitted.  Which with 50 repeats is a huge mess (they must now hit submit 50+ times!). 

I have now also found some fields that never check the required and let it send even with the broken rule.  These may be a relevant, constraint, required combo that messes it up.  This sounds like what you have.

I went back and forth with Phil on this and he said it is now a know bug and set to be fixed in the next release.  He said these relevant, constraints thing was completely overhauled in 3.3.  And they did not get it right.

I really hope it gets fixed soon as this is delaying my field season with hundreds of people.

Hope that helps

ForestSwaciak
New Contributor II

Thanks for the confirmation! We were getting very confused as to why this was happening. 

For now, our work-around is just going to be adding red colored notes that appear at the end of the survey stating that a specific question has not been answered. It is not ideal but our field season is starting soon as well and we will have to go with this if there is no definitive fix soon. 

Thanks again!

0 Kudos
DougBrowning
MVP Notable Contributor

Yea my field season starts May 6 and users/me are freaking out a bit.  It is just so confusing to the users when errors get caught at random times.  Note I also see it not always triggering when leaving a field which is supposed to work.  They keep telling me to fix it and I keep having to say I cannot.

I hope 123 starts to get that most field work is season based.  This may mean adjusting the release timing.  Not just to get it out before the season starts but also to NOT release during.  I know a number of people who had working forms break during the season due to app updates.  I wish I could lock this down somehow.

Good idea on checking for empty at the end.  ( Not much help for constraints though. ) Not sure how I could get that across 50-100 repeats though.  I could maybe figure out there is one but not which one.  

Hopefully this will add to its importance to get fixed.  I have been surprised no one else has noticed the issue.

0 Kudos
ForestSwaciak
New Contributor II

So I am not sure if this will help with your issue, but I found a work-around that as far as I can tell works.

For each field that had a relevant field causing this error, I put into its own group and moved the relevant expression to the same row as the "begin group" row.  

It adds a lot of rows by creating groups for singular questions, but does not add anything to the survey itself. I would give this a shot and let me know if this fixes your issue as well. 

DougBrowning
MVP Notable Contributor

Thanks that totally worked!  In my case I have a few questions that naturally could be a group and so this helped me get around most of what I needed.  Not all though.

This really helps with one of the big requireds we needed.   Thanks again.

0 Kudos
AdminAccount2
Occasional Contributor

I have just discovered this issue in one of my newer surveys. A field that is required, is within a repeat and contains a relevant expression is ignored - the user can submit the survey regardless whether or not the required field is filled out. App version (iOS) is 3.11.164, Survey123 Connect version is 3.11.123.

Is there any update on when this issue may be fixed? Coming up on two years since this initial post.

0 Kudos
LeZu
by
New Contributor

I have a similar issue. I have a field with a constraint and a constraint-message, created in Survery123 Connect. When submitting the form in Survey123 Connect while I'm not fulfilling the constraint, I get a new window with the constraint-message and the form is not possible to submit, just as expected.

When trying to do the same on the web, after publishin the form, I do not get the constraint message when submitting and it is possible to submit the form which is NOT as expected.

What may be the problem? 

0 Kudos