Survey 123 and Hosted feature layer

262
4
11-16-2021 09:35 PM
TobyStewart2
New Contributor II

I have been following a video of working with hosted feature layers from captured survey data.

https://www.youtube.com/watch?v=E5tW7YIniNo

I created the survey and have added a hidden field called status that when saved should like in the video create a field that is "no" to Null values and has a default entry.

I am unable to replicate this, once the Feature layer is created it is always "yes" to Null values and the default value doesn't appear?

I can create the field post Feature layer creation but my understanding is that this wont transfer across into the Stakeholder or Fieldworker feature layers?

 

0 Kudos
4 Replies
Philip-Wilson
Esri Notable Contributor

Hi @TobyStewart2,

Did you create the survey with Connect or web designer? And where/how did you create the additional hidden field?

Regards,

Phil.

0 Kudos
TobyStewart2
New Contributor II

Thanks @Philip-Wilson 
I created the survey in Connect and have created the hidden “status” field in the xls connect sheet.

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi @TobyStewart2,

Using the hidden question type in Survey123 XLSForm or using the hidden appearance, just creates a normal text field with same default as a non-hidden text field. It does not change the null values or default entry. In this case the hidden is just applied to Survey123 and when the form is displayed in the field app or web app.

Regards,

Phil.

0 Kudos
DougBrowning
MVP Notable Contributor

Do you mean the settings on the feature service?  123 does not use the Null values allowed thing like Field Maps does.  It takes care of required in the form.  It does not use default value in the service also.  All in the form.