Status of Survey123 Connect 'Relevant' Webform BUG-000108880

361
1
Jump to solution
03-21-2020 01:13 PM
Zach_Robinson
New Contributor III

I've created a survey in Survey123 Connect that uses the 'Relevant' field to show/hide subsequent questions. I discovered after publishing my survey that the relevant expressions are not honored on the Survey123 website. A google search led me to BUG-000108880: Surveys created with Survey123 Connect for ArcGIS wh.. 

Is there a status update on this bug or a proposed workaround?

I'm using field calculations to compare a user's employee ID to their birthday for a COVID-19 health screening survey. If there's a match then they should be shown the relevant questions but this doesn't work in the website. I'd love to hear any proposed workarounds. Thank you!

James Tedrick ‌

0 Kudos
1 Solution

Accepted Solutions
JamesTedrick
Esri Esteemed Contributor

Hi Zachary,

This bug concerned the use of multiple choice questions in evaluating a relevant condition.  It was closed as due to form author error - the samples provided used an equal check to determine if a choice is selected; with select multiple questions, the selected(${q}, 'value') function must be used.

View solution in original post

0 Kudos
1 Reply
JamesTedrick
Esri Esteemed Contributor

Hi Zachary,

This bug concerned the use of multiple choice questions in evaluating a relevant condition.  It was closed as due to form author error - the samples provided used an equal check to determine if a choice is selected; with select multiple questions, the selected(${q}, 'value') function must be used.

View solution in original post

0 Kudos