set a default basemap on web form + web form preview

621
10
03-23-2020 09:23 AM
JayH
by
New Contributor III

Hello all, 

Is there any way to set a topo map as a default basemap on web form? 

and wondering why there is no web form preview version. It's challenging while testing the survey because the preview and web form behaves differently in its appearance and functionalities. it would be great there is an option to preview surveys in the web form version.

Tags (2)
0 Kudos
10 Replies
Shwu-jingJeng
Esri Regular Contributor

Hi Jay,

The current 3.8 web app does allow you to set the default map and preview the survey. Aren't they working for you?

0 Kudos
JayH
by
New Contributor III

I am using connect, and it does not seem working. Is it only supported in survey web design only?

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Jay,

Here are the basemaps we currently support in Connect, when you set it in Connect, the webform will honor it.

Currently, there is no webform version preview in Connect. Please note that Connect and web designer offer different funtionality and we try to sync the support for both Connect and web designer. You will see one being support and the other does not with certain functionalities. To honor the default basemap in web designer in the field app, we currently have a working salesforce issue open:

BUG-000124917: Default Map location from web designer is not honoured in field app.

Hope this help to clarify your question.

Thanks,

0 Kudos
JayH
by
New Contributor III

Hello Shwu-jing, Thanks  for your comments. Although I selected a topo map under setting > detailed map display, my survey always shows image as a default basemap. I assume that this is a bug?

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

The issue you described sounds like BUG-000126720 Basemap selected for GeoPoint question in Connect for Survey123 is not honored when viewing the survey through survey123.arcgis.com.

This issue is addressed in 3.8 website.

Check survey123 website and under Settings tab, did you choose the option "Always use the latest version(3.8)?

You will either need to change the basemap and republish the survey in Connect and view it on 3.8 website.

0 Kudos
JayH
by
New Contributor III

It works now after checking "always use the latest version" option. Thanks so much!

Cheers,

Jay

0 Kudos
BrianCulpepper
New Contributor III

Hello Shwu-jing Jeng,

I'm currently using version 3.9.120 of Survey Connect and I wonder when other ESRI basemaps will be supported as DEFAULT base maps when a survey form is opened within a web browser?  I have already added additional, Custom web maps within the Connect Settings tab "LInked Content".. and end-users can switch to those basemaps, but new users seldom do so...  It's close to what I need, but I'd really like to specify one of the Linked Content URL's as the default basemap..   If nothing else, could we add World Imagery - Hybrid to the choices?

So, I wondered if I can set the default basemap within the XLSform <geopoint> attributes?  Have I missed this feature within the help docs?

thanks very much!

brian

0 Kudos
Shwu-jingJeng
Esri Regular Contributor

Hi Brian,

Have you joined our earlyadopter program(EAC) before?

Welcome to our Customer Validation site. 

We recently published a documentation regarding the new change of the basemap support.

Please log into our EAC website and read this article of the upcoming change for basemap support:

0 Kudos
BrianCulpepper
New Contributor III

Shwu-jing Jeng,

Yes, I am enrolled in the EAC program, and appreciate the reference..  I had a geonet credential hiccup when I last searched for the Early Adopter content...  That happens sometimes.. the ESRI global acct vs one of my existing AGOL org accounts..  

thanks for the tip and I'll look forward to 3.10's release...  not a chance that adding the map="my favorite basemap" into the XLSform will work in 3.9.120  ?

thanks very much;

take care!

brian

0 Kudos