Send Error - Survey not sent

494
2
08-29-2022 07:07 AM
PanGIS
by
Occasional Contributor III

Hello everybody.

  • I have a survey that is updated by a user through Inbox.
  • The survey sends updates with my account and other creator accounts, so it works
  •  
  • This survey needs to be updated by a Fieldworker editor userType
  • The survey record (a repeat) is created by a member with another survey and then updated by this one
  • The survey (map and feature view as well) is shared with a group and this user is a member and in the "Who can submit to this survey?" this group is checked
  • The feature service view is editable
  • The survey is set to be used with the latest version 
  • What can submitters do?:...... I tried all three options with the same result
  • The result is the one in the picture..

If I add this member to a shared edits group (by changing from Fieldworker to Creator) and by adding this group in the sharing Updates of the survey, then this user can send the survey.

 

What am I missing?

Thank you!

PanGIS_0-1661781764367.png

0 Kudos
2 Replies
ChristopherCounsell
MVP Regular Contributor

Shared Updates Groups should not be used for feature editing related; it is for updating content. I would not recommend exploring this as a conventional group for editing or as a means of troubleshooting access.

Can you provide the XLSForms you used?

If you are updating a repeat in an existing survey via the inbox, you need to enable parameters for the record to be edited. The XLSForms will help show what is occurring. e.g. add the below to the esri bind parameter for each begin repeat:

query allowUpdates=True

https://doc.arcgis.com/en/survey123/desktop/get-answers/editexistingdata.htm

0 Kudos
PanGIS
by
Occasional Contributor III

Hi @ChristopherCounsell, thank you for you reply.

the Shared Updates group was just a test to check whether the user could send.

 

The Survey is part of a group of survey that update in a sequence. the allowUpdates=True is set and it works.

The survey works with some accounts, the only difference I see between those that are working and those that are not is being part of that Shared Updates group.

It doesn't work with the FieldWorker, even though everything seems to be shared correctly.

0 Kudos